Power Plans do not work

Discussion in 'Windows 7 Help and Support' started by ameneses54, Sep 28, 2010.

  1. ameneses54

    ameneses54 Senior Member

    Joined:
    Sep 28, 2010
    Messages:
    26
    Likes Received:
    0
    I recently installed a fresh copy of Win 7 Home Premium on a Dell Dimension 8400.
    Apparently everything is fine up to now, except that I can't get any power plans to work.
    The display does not turn off and the sleep mode doesn't kick in, not even the screen saver works.
    With XP Pro I had no issues.
    I updates my Nvidia drivers to the latest release for Win 7.
    Please advice.

    Arturo
     
  2. zigzag3143

    zigzag3143 Honorable Member
    Microsoft MVP

    Joined:
    Jun 2, 2009
    Messages:
    812
    Likes Received:
    115
    Is the 8400 a P-IV desktop? If I remember correctly there was an 8400 several years ago, but its mobo and BIOS are so old they are probably not supported in win 7. Did you run the upgrade adviser before installing win 7?



    Ken J
     
  3. ameneses54

    ameneses54 Senior Member

    Joined:
    Sep 28, 2010
    Messages:
    26
    Likes Received:
    0
    Hi,
    I found a posting with the same problem and the proposed solution was to update the mouse,keyboard and display drivers,particularly the USB , which I did.
    Everything is working fine now and Win 7 is blazing.
    The only problem now, is that my Dell 8400 may last another 7 years.

    Arturo
     

Share This Page

Loading...