Preventing Win 7 From Automatically Installing Graphics Driver?

#1
Hi,
I have Windows 7 Professional 64 bit and an NVIDIA GTX 275 Graphics card. I have been using a driver that I had to search for that would not interfere with and cause problems with my Flight Sim program. I have been using it for about a year now since it solved my graphics problem, and lately I noticed the graphics problem I was having had returned.
Upon troubleshooting I found my graphics driver had somehow been updatded to a newer version from this past October. I rolled the driver back to the one I wanted and just noticed the newer one has been reinstalled again.
Does this happen when Windows does its updates? How do I prevent Windows 7 from automatically updating this driver? Thanks. Tom
 


Last edited:

Joe S

Excellent Member
#2
If it's from Windows Update you should be able to mark it so it doesn't show again. When you install the driver make sure it doesn't have automatic update enabled.
Joe
 


zvit

Honorable Member
#3
Also, when you see it in windows updates (it should be under "optional updates") right click it and choose "hide update".
 


#4
Thanks for the help, guys.
I found the NVIDIA line under installed updates but it is not under optional updates so far.
How and where do I check to see if automatic update is enabled? Thanks again. Tom
 


zvit

Honorable Member
#5
On the right side, in the Windows Updates window, there is "change settings" where you have all the flexibility to determine how Windows handles updates.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top