Printer drivers fail to load

Discussion in 'Windows 7 Help and Support' started by Bill, Feb 17, 2013.

  1. Bill

    Bill New Member

    Joined:
    Nov 3, 2011
    Messages:
    26
    Likes Received:
    0
    Windows 7/64

    Can anyone explain why sometimes my printer drivers fail to load on startup.
    In the "Devices and Printers" when they show all works fine then the next time I bootup -nothing appears.

    My printers Canon 4200/HP 7510e wireless

    I seem to think this started when I bought the HP ? but not sure.

    When they fail to load and I try to print the message "Print spooler file isn't working"

    I have deleted and reinstalled the drivers without success.

    Any help much appreciated.
     
  2. helpifIcan

    helpifIcan Extraordinary Member

    Joined:
    Jun 20, 2009
    Messages:
    768
    Likes Received:
    23
    I had this same problem last year, I finally did an inplace reinstall of WIN7and the problem went away. Not sure if that fixed it but a fairly easy fix if it works for you.

    REMEMBER before you do this back up your drive just in case.
     
  3. Bill

    Bill New Member

    Joined:
    Nov 3, 2011
    Messages:
    26
    Likes Received:
    0
    Thanks for the reply, but I bought my computer from Dell last year and the OS was
    already installed and without a Windows7 CD.

    I've gone to Start/Search and entered "services.msc" and opened the "print spool file" and
    switched it off but I dammed if can find the files to delete.
    Anyway will keep chipping away then if all else fails will have to take it to someone who can
    fix it.

    Thanks
     
  4. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,051
    Likes Received:
    302
    Hi

    When you got your Dell there was a link on the desktop or Start Menu that will create a DVD with the OS.
    You should see if you can find it and make a disk.

    You can also download the Windows 7 install disk legally from...

    Download Windows 7 ISO (Official 32-bit and 64-bit Direct Download Links) « My Digital Life

    Make sure you download the same version that you have i.e. pro, Home Premium etc.

    As for the Printer...

    Have you tried unplugging the printer and plugging it back in when the drivers don't load?
    Sometimes that will prompt it to get with it.

    Mike
     
  5. Bill

    Bill New Member

    Joined:
    Nov 3, 2011
    Messages:
    26
    Likes Received:
    0
    The good news - I've fianally got the print spool running again.

    Went to Start/typed Services.msc and opened Print Spooler properties. On the general tab I tried to click start but kept getting
    error 1053 ? so I went to the next tab "Log On" and unchecked the "allow service to interact with desktop" then went back to the general tab.
    This time I could click the Start and Apply and all the printer drivers came back ( even thought I'd deleted them ) and I could print again with both printers.
    The bad news. Came to boot up this morning and the same thing - missing drivers ? but this time did the above and the printers loaded again.
    Something is causing this to happen but eh I'm nearly there with sorting it.
    Thanks for all the help.
     
  6. Bill

    Bill New Member

    Joined:
    Nov 3, 2011
    Messages:
    26
    Likes Received:
    0
    Printer Spooler problem.
    Went back into the Spooler properties and in the "LogOn" tab I unchecked the "allow services to interact with desktop"- and left it uncecked then rebooted.
    Both drivers now load without problem....hope this has cured the problem.
     

Share This Page

Loading...