Printers Not Working.

Ok, so I used the W7 Bata, RC and now I've installed W7 Ultimate. In the previous two versions, I was able to install and run my local and networked printers.

I've now installed W7 Ult and my printers install without any issues, they just don't print. I don't get an error. The print job will stay in the queue and don't error out. (left it in there for 30 min) I've tried using the compatibility feature and it says that it doesn't see anything wrong with the drivers, or the printers. I've tried setting them up as local, as TCP ports, Paralell ports...doesn't matter. I can't get a job to print out.

Anyone else seeing this? If so, did you work it out?


Essential Member
Try clicking on the Security tab, click the Add button and browse to the network location and select users that are able to print. and add the group that you want to be able to print.

Also make sure the Print Spooler Service is running and set to Automatic on all computers with printers attached.

Print Spooler is running and set to automatic. Security is set correctly for the printers.

The weird I've left a print job up all night...and what I noticed is that there's no status. None. It's just sitting in the queue not trying to do anything. I click restart on the job and it doesn't do anything.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.