Problem with Data Execution Prevention

Discussion in 'Windows Vista Help and Support' started by Valeri, Oct 25, 2008.

  1. Valeri

    Valeri New Member

    Joined:
    Oct 25, 2008
    Messages:
    4
    Likes Received:
    0
    Hello, My name is Valeri Ivanov. I have a problem with my Windows Vista Home Basic. I have had that problem since i have bought this computer and i would like to solve it.

    The problem causes DEP (Data Execution Prevention). I can´t turn it off. I post a picture, so you could see where is the issue. ImageShack - Hosting :: 36756816cr1.jpg

    As you can see, i have taken a screen print. You find three red boxes that i have marked.
    • I opened System menu. After that i pressed Advanced system settings button. After that computer asks administrator permission. I am an administrator so i allowed to continue.
    • Opens new window. I press under Performance Settings button.
    • Opens new window. Here is the problem. I can´t press these two buttons that are located up (Turn on DEP... and Turn off DEP...) But down this window you can see a 3. red box. And it says that i must be an administrator to use these settings. But in the 1st window i allready gave an administrator permission.
    I want to know how can i turn off DEP. DEP closes most of the programs that i want to use. Even when i want to install a new program, it closes it. I don´t like that and i want to turn it off.

    Sorry for my bad English. This is not my mother-tongue. I hope you understood what i said so please help me. When you answer, please use simple words so could understand everything.

    PS. I have allready tried to turn DEP that way also: Vista: Disable DEP or NoExecute Protection to fix Explorer Crashing | Microsoft Vista | Tech-Recipes
    But it didn´t help.
    And i have installed Service Pack 1. It didn´t help also.
     
  2. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    Have you tried turning off the UAC first?
    In "Run" type MsConfig
    Open the TAB "Tools"
    Scrll down to "Disable UAC"
    On the bottom right of the window clcik "Launch"
    Now try either method of disabling the DEP
     
  3. Valeri

    Valeri New Member

    Joined:
    Oct 25, 2008
    Messages:
    4
    Likes Received:
    0
    Oh my god!!!
    That really helped!
    Thank you very very very much !!!!!!!!!!
     

Share This Page

Loading...