Problem with drivers

Discussion in 'Windows 7 Hardware' started by JohnOne, Oct 4, 2011.

  1. JohnOne

    JohnOne New Member

    Joined:
    Oct 4, 2011
    Messages:
    6
    Likes Received:
    0
    I have a phone which I occasionally use (tethered) as my internet connection upstairs.

    It all works fine and dandy on my laptop (win 7 32) and it used to work on my PC until I messed it up, after it failed and I tried to install drivers for it. it went badly wrong and I tried loads of drivers and now it just wont work.

    I'm not quite certain of the the terms or how to explain, but I'll do my best.

    on my computer in driver details under device manager it has a whole host of things that seem to be associated with it, here's a pic to show what I mean.

    driverproblem.

    The list is quite long

    On the laptop where everything works, and on another PC i tried, the only details in that same gui are the one selected in that image, and the one directly above it.

    driverproblem2.

    How can I get rid of them all?

    I'm at the point now where I was about to start looking in the registry and start deleting stuff, but thought better of it.

    The phone just wont connect to the internet while its tethered to PC (for internet sharing that is) it will connect on its own screen with internet explorer (yes its windows phone 6.3).

    I'd appreciate any advice. I'm fairly sure its all these drivers I tried. I basically ballesd it up when the original problem was my isp (thanks booze)

    Oh the phone has no driver disk, win 7 just picks it up, and installs windows mobile device center. (edit) which I've also tried uninstalling.

    The phone is an O2 orbit 2 xda
     
  2. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,455
    Likes Received:
    268
    Easiest way out would be a system restore back to some date when it still worked.
     
  3. JohnOne

    JohnOne New Member

    Joined:
    Oct 4, 2011
    Messages:
    6
    Likes Received:
    0
    Thanks, I thought about that, but alas, far too late, this happened a couple of months ago and I've installed tools and software and such.

    I'm beginning to think a fresh install would be the only way, but I really don't want to do that as I have my environment set up pretty much the way I like it, and don't fancy re-installing visual studio again, it took about an hour.
     
  4. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,455
    Likes Received:
    268
    Try removing the device under device manager and rebooting - I'd expect Windows to find and reinstall.
     
  5. JohnOne

    JohnOne New Member

    Joined:
    Oct 4, 2011
    Messages:
    6
    Likes Received:
    0
    Tried every combination of uninstalling and rebooting I can, even uninstalling mobile device center, I should have mentioned that, sorry.

    If I troubleshoot network problems, It detects an invalid IP and resets/repair it, and providing my phone has been rebooted and not connected to the pc via usb, it will be detected and set up as
    Remote NDIS based internet sharing device, and only the two items in the driver info window appear, and I can connect the phone and it will work fine.

    But when I disconnect it, I'm back to square one, it gets seen as a windows device (shown in first pic) with all those items in the box and I have to reboot both the PC and phone and start the whole procedure again.

    I thing related is that My network cards (I have two) are knows as network device #3 #9. if you know what I mean, I'd love to be able to get those back to 0 and 1 since there are only 2.

    I'm really stuck here.
     

Share This Page

Loading...