Problem with Edimax EW-7128g(Ralink RT61 chipset).

Discussion in 'Windows 7 Networking' started by FruitlessnesS, May 15, 2009.

  1. FruitlessnesS

    FruitlessnesS New Member

    Joined:
    May 15, 2009
    Messages:
    2
    Likes Received:
    0
    Hi there.

    Recently I encountered problem with my wireless Network Adapter Edimax EW-7128g (with Ralink RT61 chipset). The problem started when i upgraded my PC with new RAM memory (from 2gb to 4gb). When I browse internet Windows suddenly freeze and only thing that helps is restart, I can't move cursour and system does not respond while freezed. I'm sure that's not memory fault cause it passed memtest few times. While this problem occurs in Windows7 64bit it's rock solid in old good Windows XP SP3. I tried offical drivers from ralink site and they didn't help.

    My specs are:
    CPU-c2d E6600
    GPU-8800GTS 320Mb
    Mainboard-Gigabyte GA-P35-DS4
    Soundcard- Creative X-Fi Fatality

    Cheers.
     
  2. Matthew Hayward

    Matthew Hayward New Member

    Joined:
    Jun 1, 2009
    Messages:
    2
    Likes Received:
    0
    I think it's a common problem, I have the same issue using the same wireless card, but it's fine over a network cable. I suspect there's something wrong with the ralink drivers.
     
  3. dominic1967

    dominic1967 New Member

    Joined:
    Sep 22, 2009
    Messages:
    2
    Likes Received:
    0
    More of the same...

    I tried two separate EW-7128g PCI cards in my Win7 newbuild and although drivers would appear to install correctly and they showed up in device manager, the adapters would show as "disabled", no matter what I tried.

    I then tried a Rosewill RNX-N300, which also just happens to have a Ralink chipset and it didn't work, either. So on a whim, before giving up on my mobo, I tried a Netgear card with an Atheros chipset and it worked beautifully, right outta the box. So three non-working PCI cards with two different Ralink chips tells me it ain't Windows 7's fault. It's Ralink, which just happens to be in a boat-load of PCI and USB adapters out there right now.
     
  4. mdmower

    mdmower New Member

    Joined:
    Sep 24, 2009
    Messages:
    24
    Likes Received:
    0
    Sorry to drag out such an old post, but I think there are STILL problems with RALink based wireless card drivers in Win7 x64.

    I have two Win7 x64 computers running two different wireless cards (acutally one PCI card, the other USB) based on RALink chipsets. Even with the latest drivers from RALink Drivers both machines would randomly freeze. When I uninstalled the drivers and removed the devices from the systems, the freezing stopped.

    This was using the driver dated 9/25/2009 for USB (RT2870 /RT2770 /RT307X /RT2070 /RT3572), and the driver dated 8/24/2009 for PCI/mPCI/CB (RT256x/RT266x).
     

Share This Page

Loading...