Problem with sharing a folder to XP

Discussion in 'Windows 7 Networking' started by Psyfer, Dec 6, 2009.

  1. Psyfer

    Psyfer New Member

    Joined:
    Dec 6, 2009
    Messages:
    4
    Likes Received:
    0
    Hi. I have a little problem that is driving me insane. I have looked and looked on the net and through these forums with no luck.

    First, let me tell you my network setup.

    1x Laptop with XP pro (using wireless)
    1x Desktop with Win7 Ultimate (using wire)
    1x DSL/WiFi router/modem combo (ISP is Verizon DSL, wireless is turned off)
    1x Apple AirPort Extreme (mainly for the NAS/Wireless N feats.)

    Ok, my problem is with the desktop. I am trying to share out a folder. I want ALL FILES AND SUB-FOLDERS SHARED. What I get is just the files that are in the ROOT of the share. I have tried all kinds of ways to get this done but I have no luck doing so. Both of the computers can see each other, talk to each other, ping, you name it. But for the life of me the Win7 pc will not let me access the sub-folders on the XP laptop. As I said, I can access all the files in the ROOT of the share on the XP laptop, even write to them, but can't access the sub-folders. I can make a share on the XP laptop and access all the files and sub-folders with writing abilities on the Win7 pc. I did manage to get the sub-folders to show up in the ROOT of the share on the XP laptop, but I get an "Access is Denied" box when I try to access it. If anybody knows how to fix this, I would greatly appreciate it.
     
  2. Psyfer

    Psyfer New Member

    Joined:
    Dec 6, 2009
    Messages:
    4
    Likes Received:
    0
    No body knows anything?
     
  3. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Nope, don't know anything and I can prove it, just listen....The part that I highlighted in red, probably has nothing to do with Win7 and more to do with "Inheritance" on the XP Laptop. Try right clicking on the "Root" of the share, choose properties, under the security tab, click advanced button near the bottom, uncheck the inherit box on the bottom if prompted choose copy and then check the box that says replace permissions on child objects and then OK your way out of there and see if that accomplishes what you were after.
     
    #3 Trouble, Dec 14, 2009
    Last edited: Dec 14, 2009

Share This Page

Loading...