Problem with Windows Media Centre

Discussion in 'Windows 7 Help and Support' started by quidestveritas, Jan 23, 2010.

  1. quidestveritas

    quidestveritas New Member

    Joined:
    Jan 23, 2010
    Messages:
    2
    Likes Received:
    0
    Description of Problem
    Model: Acer Aspire 4810T
    Processor: Genuine Intel(R) CPU U4100 @1.30GHz
    RAM: 3MB
    Operating System: Windows 7 Home Premium

    When turned on, Windows Media Centre automatically starts. Starting any program activates Windows Media Centre. Disabling Windows Media Centre means any attempt to start a program results in the following error message:

    “Windows cannot open this program because it has been prevented by a software restriction policy. For more information, contact your system administrator.”

    Re-enabling access means the same problem re-appears.

    Also, on the Desktop, none of the programs have their regular icons, only the generic green-on-white Microsoft icons.

    The computer belongs to an education volunteer who bought it in the UK just before arriving here in Rwanda for a 2-year placement in a remote area, so the laptop is vital to his work – any advice/help/recommendations would be hugely appreciated!!
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    It would seem that a system restore to a restore point as early as feasible would be the first thing I would try. Failing that run command prompt as administrator and type sfc /scannow and see if it finds any thing and failing that a repair install might be required. Keep us posted.
     
  3. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321

    Default Program Windows 7 - How to Change the Default Program for a Specific File Extension in Windows 7


    First try changing default playback to Microsoft Media Center in Start => Default Programs.
    If it doesn't help, then:


    Try this under administrator account :

    Run gpedit.msc => Expand Computer Configuration => Administrative Templates => Windows Components => Windows Media Center
    be sure that Do not allow Windows Media Center to run is disabled or not configured. You should also check the same setting under User Configuration.


    If you don't have gpedit.msc (if 7 Premium), then very carefully and at your own risk, take a look at
    these reg keys:

    HKLM\Software\Policies\Microsoft\WindowsMediaCenter\MediaCenter
    HKCU\Software\Policies\Microsoft\WindowsMediaCenter\MediaCenter


    Change these both values to 0.


     
    #3 cybercore, Jan 23, 2010
    Last edited: Jan 24, 2010
  4. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    System restore, as Trouble suggests, can help too.
     

Share This Page

Loading...