Problems installing some applications on Windows 7

#1
Hi
I installed Windows 7 on my laptop last night. I was able to install a few applications such as Firefox and Thunderbird and Yahoo Messenger successfully. However, when I tried to install Java, iTunes, and Skype, the installation process failed. The main error that I get is mainly when the installer tries to update and write something in the registry (I get error 1406). Has anyone else had this problem too? If so, what is the solution to install such applications?
Thanks you
 


#2
Same problem to me. I can't even install antivirus software.
 


#3
I did some research online. One advice was to give "Everyone" permission to the relevant registry Key. But that did not help. I gave Full Control permission to "Everyone" for my registry, still got the error messages.
 


RAK

Extraordinary Member
#4
It is unusal that it should be a problem with permissions, on a default install. Java, for example, reuires no such permissions. Somtimes the reason can be a corrupted licence file, such as removal of the efi.cfg, or the use of one of the various posted methods of delaying activation indefinitely.
I think the easiest way to try to overcome the problem, is to log in with a Global Admin account. To do this, there are a couple of different ways:
Open a command prompt (Run as Administrator).
Type the following command and enter.
net user administrator /active
Log out and see if you have a new alternative login, as well as your existing one. If not, do it the long way.
Shut down the computer for a cold boot. Tap the "F8" key as you are booting.
Select "Safe Mode with networking" from the boot menu.
Log into windows 7 with your personal account that holds the administrator access.
Open a command window (START--->RUN--->CMD.exe). At the command prompt type the following net user administrator /active
Log out and log back in as administrator.

Another way
Go to Start
Type Control UserPasswords2.
Click Advanced.
Click Advanced again.
Select Users.
Select Administrator and untick the the box “Administrator is disabledâ€Â￾
Now log out and login as Administrator.

I would suggest, assuming this works for you, that when you have finished installing, you log back in and disable the Admin account again. For the unwary it can give you too many open priviliges.
 


#5
Hi
Thanks for your reply and suggestion. I was very optimistic that it would work. Unfortunately even as Administrator I got the same error message. So, like you, I doubt it is a matter of registry permissions, as the error messages suggest. Any other suggestion or idea is most welcome.
Thanks again
 


Krypto

Fantastic Member
Premium Supporter
#6
I am also having the same problem i think i have narrowed it down to programs that use the windows installer i can not install jave adobe reader or office and they all use windows installer also who is the maker of your laptop
 


#7
I have noticed that too. I am just wondering why only some systems have this problem with the Windows Installer.
My laptop is a Dell XPS1330.
 


Krypto

Fantastic Member
Premium Supporter
#8
Ok I got it working I had to repair install windows i stuck the disk in and chose the upgrade option and let it work I am now having no problems installing programs i hope this works for you post what happens after you do reinstall
 


#9
Great, your solution worked for me too. I had to update the BIOS of my system first when I tried to reinstall Windows 7. But after that, an upgrade install fixed the problem and I was able to install the other applications too.
Thank you.
 


Krypto

Fantastic Member
Premium Supporter
#10
Glad to here it worked for you too:razz:
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.