Problems since installing 7 - blue screen, touch pad, fn keys etc.

#1
I have a Toshiba Tecra M9 (PTM91C - TG109C). Processor: Intel(R) Core(TM)2 Duo CPU T7100. 2GB of Ram

I was using Vista (32-bit) until I received a free download of Windows 7 (64-bit) from my university. Since installing windows 7, I have been experiencing several problems. I randomly get a blue screen that says "Driver State Power Failure". This typically happens if I'm running several programs but it's not unusual for the computer to restart even with nothing running. If the computer restarts it will restart several times from the login screen if I dont log in immediately.

Also, the computer often crashes when I close and open the lid. When it's set to hibernate upon closing the lid, if I open the lid, the desktop appears (without a prompt for password login) and the computer is unresponsive until I restart it with the power button or it blue screens. Basically the computer freezes on whatever the screen was when I closed the lid and does nothing until I restart it. I changed it to "do nothing" upon closing the lid most of the time, the same problem occurs.

Also, the function keys don't work anymore and the touchpad no longer scrolls. I'm guessing these are driver issues.

Thank you, Thomas
 


Trouble

Noob Whisperer
#2
I'm guessing you're right. Go here, select Windows 7 64 bit and there looks like about three pages of drivers that should help.
Model Content Page
Hope this helps.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.