Windows 7 Problems with Realtek RTL8111B NIC


New Member
On my desktop PC I have a Realtek RTL8111B Gigabit Ethernet NIC. W7 installed fine, and has been running a few days OK. However, for some reason, today it is only connecting to my network at 10Mbps, rather than its usual 100Mbps (I can't achieve 1000Mbps due to the limitations of my Netgear DG834GT router)

I suspect this is an issue with the driver, and, upon looking in Device Manager, I have determined the driver version currently being used is 7.1.820.2008. However, when I look at the ASRock website (my NIC is built into my ASRock motherboard) the most recent driver (Vista) is 6.186.1103.2006. Furthermore, if I go to the Realtek website, the most recent driver (Vista) is 6.213.0120.

I have tried to unistall the 7.1.820.2008 driver, in order to install one of the other drivers. However, I cannot get to the stage of installing one of these drivers, as the 7.1.820.2008 driver is automatically installed whenever the system is scanned for new hardware.

So...2 questions...

1) Which driver should I be using? Is the 7.1.820.2008 driver likely to be some kind of driver written recently for W7? Or should I be using the most up-to-date Vista driver I can find?

2) How do I attempt to install another (older) driver, instead of allowing the system to automatically install the newer driver?
This should work
1) Unplug Lan cable from your computer first
3) Uninstall the driver (Remove from system) via Device manager. This should remove the software from the system
4) reboot (usually not necessary but it ususally is a good idea unlike Linux systems where you almost NEVER have to reboot after installing new hardware.
5) install the driver from Realtek -- run at least the EXE file.
6) enable the device again -- if it asks for software let it do it automatically (unless your EXE file de-compressed to a hole load of files one of wich is named xxxxxxxx.INF) in which case choose the advanced option -- have disk and point to the directory containing the .INF file.

Note another possibility is in the Device properties (from the Device Manager) under advanced you can set the speed of the NIC. try switching it from AUTO to one of the other speeds.
In general it's not a good idea to use a back level / old driver unless you really have to.


Thanks for the reply Jimbo. I have tried what you suggested, but unfortunately it didn't work. :(

Although Device Manager seems to suggest the driver in use after the 1st procedure is now the Realtek 6.213.0120.2008, I did notice that there was activity in the system tray suggesting that the newer driver was also being automatically installed. Kinda confusing!

As for your 2nd suggestion, this also does not work. Whether I manually choose 100Mbps Full Duplex or 100Mbps Half Duplex, it still connects at 10Mbps!

I'm running out of ideas, and am only really guessing that the problem lies with the driver. Perhaps it is a hardware issue, with either the NIC or the router... What I think I will try next is to boot into XP (I'm currently dual booting XP and W7) and see what the speed is like there. If 100Mbps is not achieveable under XP either, then it's not a problem with W7... Will update ASAP!

UPDATE - I have now booted into XP and have found that the NIC is still only connecting at 10Mbps. Therefore it would seem that this is not a W7 problem at all, and is something to do with either my router or NIC. Not sure where I go from here, but, as it's no longer a W7 issue, I will look for help elsewhere...

2ND UPDATE - Strangely enough, after powering off the router, rebooting into W7, then powering the router back on, everything now seems to be OK! I have also booted back into XP, and all OK there too. So, now in W7 I am using the latest Realtek Vista driver. There now doesn't seem to be a way of installing the 7.1.820.2008 driver, as both Windows Update and the automatic driver update service won't find a newer driver than that Vista driver! Will have a dig around to see what I can find online, but for now am very happy having 100Mbps running again!
Last edited: