By registering with us, you'll be able to discuss, share and private message with other members of our community.

SignUp Now!

Windows 7 Program Install Failure: Assembly install error 1935


New Member
May 4, 2009
Hi everyone,

I've been using Windows 7 Beta (6.1.7000) for a while and I haven't had any problems getting programs to install and run, until now. I recently tried to install Autodesk Inventor 2010 and the installation failed 2/3 of the way through with this error:

Error 1935. An error occurred during the installation of assembly 'policy.9.0.Microsoft.VC90.OpenMP,publicKeyToken="1fc8b3b9a1e18e3b",version="9.0.30729.1",type="win32-policy", processorArchitecture="x86"'. Please refer to help and support for more information.
The error is fatal so the installation rolls back after this occours. I checked Microsoft support with no luck, or it was just too confusing. I hope someone here can give me a hand. Reinstalling Windows 7 will almost surely fix the problem, but I really want to avoid having to.

Some info:
The installation works fine on Windows Vista Home Premium 32-bit on the same computer.
I always disable all firewall and antivirus programs before trying to install.
The installer is using Windows Installer, "msiexec.exe" runs while the installer is working.
Using Windows 7 Beta build 700 on an AMD Athlon 64 X2 TK-55, x86 based.
1 GB of RAM.
I tried installing after backing up to a restore point that was a while before this problem and it the same error occurred.
Plenty of HD space for the program.
I had this same error message while trying to install VMware Workstation 6 later.

Thank you for your time!
I'd suggest downloading the RC tomorrow (May5th) from Microsoft and installing that.. The program your trying to use may work better in the RC than the Beta.. Windows 7 RC is build 7100 just in case you were wondering.. ;) just make sure you do a CLEAN INSTALL with the RC.. :)
I'm planning on downloading the RC, but as I said I don't want to reinstall Windows unless I really have to.

According to Engineering Windows 7 : Delivering a quality upgrade experience I should be able to upgrade from Beta 7000 to RC 7100, meaning I won't have to do a clean install. If the method of upgrading described in the link doesn't work, or if the upgrade doesn't fix the problem, I guess I have no other choice than to do a clean install.

I'll still look for a solution until I have the RC ready to go. Thank you for your input, Radenight.
I would seriously still go the Clean Install route instead of an upgrade.. it's just an all around better way to move from a BETA OS to the RC.. ;) Chances are your problem will no longer exist by doing a Clean Install.. It can be a pain I know but it's worth it.. :)

I don't think you'll be able to upgrade from the beta anyhow.. I'm pretty sure you can upgrade from Vista SP1 but not from the beta build 7000.. I'll have to double check that though..

EDIT: Ok upon further investigation you actually CAN upgrade from the Beta to the RC but not without making a few 'tweaks' first... Which of course isn't really a recommended thing when dealing with BETA or RC or even RTM software for that matter.. but to each his own.. Good luck. :)
Last edited:
Did you see the link I had in my reply? It points to a blog entry on MSDN that describes how to upgrade from the beta to an RC. I guess you already read the same info somewhere...

Anyways, I will do a clean install eventually but the upgrade will be sort of a temporary fix until I find time to reinstall everything I had on the Beta after installing the RC.

Thanks for the reply!
I am also getting the exact same message when trying to install ArcGIS 9.3.1 (.msp)
It gets to the end then error message, then rolls back.

Im using the RC release. Any ideas on how to fix this?
Hey all,

I had the same problem. Couldn't find any solution but then somone said that its ad aware. I don't have ad aware but I have Avira Antivirus. So I disabled that and reinstalled and it worked fine.

It seems some antivirus packages block the installation process. I don't know why but it may be some sort of extra protection against malware.

Anyway disable your antivirus and give it a try. Remember to turn it back on agian.

only way to fix error 1935 is to run the windows 7 install repair process.
.net cant be fixed in windows 7 AT ALL. trust me, windows 7 wont even touch .net files on drive
2.0, 3.0 and 3.5 framework are build and CAN NOT BE FIXED.
the repair install worked 100 percent in fixing error 1935

url to windows 7 install fix:
Repair Install - Windows 7 Forums
[langtitle=vi]Re: Program Install Failure: Assembly install error 1935[/langtitle]

Em cung bi nhu the nay
error 1935. An error occurred during the installation of assembly component
HRESULT: 0x800736FD
Linh giao cac pro
Last edited: