Program won't run correctly unless UAC is disabled?

#1
I have a program (written by a community member for this game) that hooks into the game itself, and grabs the onscreen text. Now, the program itself works, but only when UAC is disabled. I can run it as administrator, and approve the changes it makes to the computer, however it still won't work unless the UAC is disabled.

Do any of you guys know what the problem is? When UAC is off, the program does not need administrator priviledges. When the UAC's on, when the program starts up it the UAC makes its appearance and asks if you'd like to allow this program to make changes, and i always click "yes." So I don't understand why, even though i allow it to make changes, it still can't do those changes.

My friend, the one who showed me it, runs XP and has no problem with it. if you want the link for it, if you need it, i can get you it. It's pretty simple really, just the program and a .DLL file that goes with it.
 


Joe S

Excellent Member
#2
Did you try running the program as an administrator?
Joe
 


#3
Yeah, sorry I thought I mentioned that in the OP. I've run it as administrator, as in right clicked and then "run as administrator". My account is the only account on the computer, so it has all the privileges.
 


#4
I am just curious... is the problem solved then?
 


#5
No, It is not solved. I said I have already tried it with no success. I've right clicked it to run as admin, I've changed the properties and checked off the box that says to always run as admin, and I made the settings for all users for it to run as administrator. It only works when UAC is off.
 


#6
Well, if you are the only user of your system, then turn-off the UAC. That's what I have done on my system, besides it's annoying.
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#7
HI

Yes: Unless you are protecting your system from changes by other users just turn it off.
As long as you know what you are doing there really isn't a good reason for having it turned on.

I just got sick of it asking me if I really wanted to do everything that I wanted to do and it does cause issues with some programs.

If you want to use it you could try using Take Ownership on the .exe file for the program you are trying to run and see if that helps.

Add "Take Ownership" to Explorer Right-Click Menu in Win 7 or Vista - How-To Geek

Mike
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.