Programs cant access the internet

#1
So randomly one day W7 decided to no longer let any of my programs access the internet. I mostly use Napster and iTunes but i cant cause they wont connect to the internet but firefox works perfectly fine
 


#2
You have a simple dns issue. The difficult part may be figuring out why.

There are basically two things that cause this. Installing any Apple software that installs the Bonjour service. Bonjour must be completely uninstalled if this is the case. You can check the task manager for mdnsresponder.exe to see it you have Bonjour.

Another is something changed your network settings. Please open I.E. and then go to Tools | Internet Options | Connections | Lan settings

Uncheck all the boxes there if any are checked. Ok your way out and close I.E.

Test.

If still no good, open an elevated command prompt. Copy and paste these commands one at a time, and hit enter after each. Reboot.

Code:
netsh winsock reset
Code:
netsh int ip reset

If you have the Bonjour service, we can help you remove it correctly. (Important) Do you have x86 or x64 Windows?
 


Captain Jack

Extraordinary Member
#3
So randomly one day W7 decided to no longer let any of my programs access the internet. I mostly use Napster and iTunes but i cant cause they wont connect to the internet but firefox works perfectly fine
Hello !!

What Firewall are you using ?? It's possible that Firewall might block the connection. In addition to TorrentG's suggestion try these steps.

Napster uses TCP 6699 and UDP 6699 so make sure your Router, Windows Firewall and Third party Firewall won't block it. And for i-Tunes check this article How to enable iTunes in the Windows Vista and Windows 7 Firewall

Hope this helps,
Captain
 


#4
You have a simple dns issue. The difficult part may be figuring out why.

There are basically two things that cause this. Installing any Apple software that installs the Bonjour service. Bonjour must be completely uninstalled if this is the case. You can check the task manager for mdnsresponder.exe to see it you have Bonjour.

Another is something changed your network settings. Please open I.E. and then go to Tools | Internet Options | Connections | Lan settings



Uncheck all the boxes there if any are checked. Ok your way out and close I.E.

Test.

If still no good, open an elevated command prompt. Copy and paste these commands one at a time, and hit enter after each. Reboot.

Code:
netsh winsock reset
Code:
netsh int ip reset
If you have the Bonjour service, we can help you remove it correctly. (Important) Do you have x86 or x64 Windows?

Thank you so much!! all i had to do is uncheck some stuff in IE thank you!!!!
 


#5
You're welcome. Glad I could be of help. :)
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top