Public Wi-fi: connected but locked-out

jpoc

New Member
#1
Hi All

Hope soneone can assist with a problem that is driving me nuts.

I automatically connect fine at home either by cable or wi-fi. The problem is when I am out using a public wi-fi (or even cable if in a hotel).

I can connect. But what I cannot access is the public isp's registration page so that I can click or code-enter to use their system.

With Windows Vista I would connect and then when I opened IE or Firefox the home page would automatically divert to the public isp's log-on page. No problem. Windows 7 (for me anyway) does not do this. Instead sometimes a ballon opens saying additional log-on info required. When that is clicked I go to the isp page, so no problem. But mostly that ballon doesn't come up. It doesn' even always come up when accessing a previously "sucessful" site before.

All IE does is try to open my usual home page which fails becaus eI have not registered with the public isp yet.

I have tried all the obvious stuff - conencting/reconnecting, opening and closing IE and Firefox etc, swithching the firewall on and off. The hardware says it is working fine and it obviously is given I can connect at home and 9sometimes) when out.

Any ideas? this is killing me as I need to travel for work a lot. Any help much appreciated.

James
 


reghakr

Essential Member
#2
Hello James and welcome to the Windows 7 forums.

This statement is a bit confusing:

I can connect. But what I cannot access is the public isp's registration page so that I can click or code-enter to use their system.
Actually this problem has to be dealt with by the place where you are trying to use their network.
 


jpoc

New Member
#3
public wi-fi lock out - response

Hi Reghakr

Thanks for taking the time to respond.

All the public wi-fi/hotel cabled sites that I cannot access are ones that I used to be able to access automatically when I had my last (Vista OS) laptop.

Because of this previous success I feel that the problem lies with my laptop (and, I suspect, Windows 7). The isp's sites and their set-up haven't changed. What has changed is the way that Windows 7 intereacts (sporadically) with them.

Since posting I have tracked down my event log and the problem may (I stress "may") lie with Event 34001 - Shared Access_NAT ... "The ICS_IVP6 failed to configue the IPv6 stack".

Any thoughts?

Regards
James
 


Trouble

Noob Whisperer
#4
Hi Reghakr

Thanks for taking the time to respond.

All the public wi-fi/hotel cabled sites that I cannot access are ones that I used to be able to access automatically when I had my last (Vista OS) laptop.

Because of this previous success I feel that the problem lies with my laptop (and, I suspect, Windows 7). The isp's sites and their set-up haven't changed. What has changed is the way that Windows 7 intereacts (sporadically) with them.

Since posting I have tracked down my event log and the problem may (I stress "may") lie with Event 34001 - Shared Access_NAT ... "The ICS_IVP6 failed to configue the IPv6 stack".

Any thoughts?

Regards
James
Good catch, it looks like you may be on to something, how about trying to just disable by unchecking IPv6 in the properties of you network adapter. Type ncpa.cpl into the search box or run dialog box, on the resultant page select then right click on the adapter and choose properties. Take the check mark out of the box adjacent to IPv6. Let us know if that does the trick
 


jpoc

New Member
#5
Public wi-fi lock-out

Hi Randy,

Many thanks for both your patience and your swift response.

I've unticked the box as suggested - on both the Intel wi-fi link 5100 AGN adapter and on the Marvell Yukon adapter which appears to be for cable connections.

I won't know if your solution works until I take the laptop for a walk to a public wi-fi area - which won't be for a wee while yet as I am stuck in a Hong Kong hotel room doing some heavy duty desk-work.

So in just under a week I'll know the outcome and will post the results here. Until then, thanks for your support thus far!

James
 


reghakr

Essential Member
#6
Good luck James:)
 


#7
Re: Public wi-fi lock-out

Hi Randy,

Many thanks for both your patience and your swift response.

I've unticked the box as suggested - on both the Intel wi-fi link 5100 AGN adapter and on the Marvell Yukon adapter which appears to be for cable connections.

I won't know if your solution works until I take the laptop for a walk to a public wi-fi area - which won't be for a wee while yet as I am stuck in a Hong Kong hotel room doing some heavy duty desk-work.

So in just under a week I'll know the outcome and will post the results here. Until then, thanks for your support thus far!

James
I was having the same issue and this fixed worked for me. I deselected the checkbox for TCP/IP v6 in the properties for my wireless network adapter and I am now happily emailing this from my local coffee shop. Thank you so much! I have attached a screenshot just to help anyone that is visual like me.
 


Attachments

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.