Put in new video card, getting all sorts of weird problems

Discussion in 'Windows 7 Graphics' started by supaafly, Apr 13, 2011.

  1. supaafly

    supaafly New Member

    Joined:
    Mar 12, 2010
    Messages:
    20
    Likes Received:
    0
    I have a Lenovo K320 desktop.

    Came out of the box with:
    Intel® Core™ i7-870 Processor ( 2.93GHz 1333MHz 8MB )
    ATI Radeon HD5570
    8 GB PC3-10600 DDR3 SDRAM 1333MHz
    1TB 7200
    280W Power Supply

    I wanted to beef up my gaming so I got a new GFX card which required a new power supply. I upgraded to:

    500W Rocketfish Gaming Power Supply
    Radeon HD 5750

    Took a bit to configure my display but its now showing right at 1920x1200 on my 23" tv.

    Now I do run into occasional problems. I can run games FLAWLESSY awesome better than before. My problems come when I do video editing.

    If I record some gaming with Fraps at full screen and go to even just WATCH one of the videos my PC locks up and I have to restart it via the power button. Same things happens sometimes when I record at HALF screen (ends up with 960x500 or something video) and when I go to edit the videos in Camtasia studio my pc will just lock up and freeze completely.

    I could edit videos JUST FINE before I upgraded with no lock ups. My pc should be able to handle this. Especially even better now. any ideas?
     
  2. bassfisher6522

    bassfisher6522 Essential Member

    Joined:
    Aug 27, 2008
    Messages:
    4,884
    Likes Received:
    318

Share This Page

Loading...