Question About Image Preview?

Discussion in 'Windows 7 Help and Support' started by MikeHawthorne, Sep 11, 2011.

  1. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,045
    Likes Received:
    300
    Hi

    Until recently my computer would open image files with Adobe Photoshop and Preview them using Windows Photo Viewer.
    This is the way it has worked in Windows 7 as long as I have been using it.

    This worked great because Photo Viewer open almost instantly and Photoshop takes forever!

    About a week ago, probably after some Windows updates, it started "Opening" everything in Photo Viewer instead of Photoshop.

    I changed the default program back to Photoshop, I had to do this with every image format, from BMP to TIf one at a time, but I got it so when I want to open an image, to edit, it comes up in Photoshop.

    The problem is that it now does the same thing with anything I want to preview!

    That's a real pain, because I work with images all day long.

    So my question is how do I get it to respond to the "Preview" command with Picture Viewer without changing the default action for "Open"?

    I've looked and I can't find any place that lets you change this setting.

    Any help appreciated.

    Mike
     
  2. kaos

    kaos Senior Member

    Joined:
    May 9, 2011
    Messages:
    1,747
    Likes Received:
    33
    im consfused lol

    Are you wanting to edit picture is photoshop but to preview them in photoviewer?

    sorry im just being slow tonight lol
     
  3. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    How does/did it work Mike? E.G. If I double click an image it opens with XnView (read Windows Photo Viewer). But I use Open with... to open in Photoshop. Or were you right clicking the image and selecting Preview to see them in Windows Photo Viewer but double clicking for PS??

    As you can see from this list, I actually delete the preview from a lot of my context menu!! But it will at least show you the keys to look out for!
    Code:
    [-HKEY_CLASSES_ROOT\SystemFileAssociations\.dib\ShellEx\ContextMenuHandlers\ShellImagePreview]
    
    [-HKEY_CLASSES_ROOT\SystemFileAssociations\.gif\ShellEx\ContextMenuHandlers\ShellImagePreview]
    
    [-HKEY_CLASSES_ROOT\SystemFileAssociations\.ico\ShellEx\ContextMenuHandlers\ShellImagePreview]
    
    [-HKEY_CLASSES_ROOT\SystemFileAssociations\.jfif\ShellEx\ContextMenuHandlers\ShellImagePreview]
    
    [-HKEY_CLASSES_ROOT\SystemFileAssociations\.jpe\ShellEx\ContextMenuHandlers\ShellImagePreview]
    
    [-HKEY_CLASSES_ROOT\SystemFileAssociations\.jpeg\ShellEx\ContextMenuHandlers\ShellImagePreview]
    
    [-HKEY_CLASSES_ROOT\SystemFileAssociations\.jpg\ShellEx\ContextMenuHandlers\ShellImagePreview]
    
    [-HKEY_CLASSES_ROOT\SystemFileAssociations\.png\ShellEx\ContextMenuHandlers\ShellImagePreview]
    
    [-HKEY_CLASSES_ROOT\SystemFileAssociations\.rle\ShellEx\ContextMenuHandlers\ShellImagePreview]
    
    [-HKEY_CLASSES_ROOT\SystemFileAssociations\.tif\ShellEx\ContextMenuHandlers\ShellImagePreview]
    
    [-HKEY_CLASSES_ROOT\SystemFileAssociations\.tiff\ShellEx\ContextMenuHandlers\ShellImagePreview]
    
    [-HKEY_CLASSES_ROOT\SystemFileAssociations\.wdp\ShellEx\ContextMenuHandlers\ShellImagePreview]
     
    #3 Elmer, Sep 11, 2011
    Last edited: Sep 11, 2011
  4. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,045
    Likes Received:
    300
    Hi

    The way it has always worked before is that, if I right click on an image file or thumbnail in Windows Explorer and click Preview it open in Windows Picture Viewer, which is almost instantaneous.

    If I right click on an image file or thumbnail and click open it opens in Photoshop.

    It's always worked this way until a week or so ago, changing the open with option changed where the file opened for editing, but did not effect how opened to be previewed.

    I figured that was the purpose of the "Preview" button.

    If I wanted to open it I wouldn't need to preview it. LOL

    Now it wants to do the same for both of them. Either they both use Photoshop or they both use Picture Viewer.

    I wan't to get it back the way it was before, Open = Photoshop... Preview =Windows Photo Viewer.

    Mike

    Ok I think this is only happening with certain file types.

    With jpg files it works the way it always did.

    But with .tiffs, (most of my pictures) if I assign Photo viewer as the primary program, then Preview moves to the top of the menu and Open is removed from the list completely.

    If I assign Photoshop as the primary then Open moves to the top of the list and Preview moves down on the list.
    However the both still point to Photoshop and I can't preview the file.

    Weird.
     
  5. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,045
    Likes Received:
    300
    Hi Elmer

    I did find the Registry entry but don't see anyway to change it manually.
    It doesn't list the assigned program for Preview as far as I can see.

    Mike
     
  6. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    Well, you'll be pleased to know that I changed .BMP to the same as you have and I'm now having exactly the same issue (Damn!!).

    I'm lost on this one! I'm thinking along the lines that when PS is installed it changes registry entries so that a (.TIFF) TIFFFile becomes a Photoshop.TIFFFile.12, a (.png) pngfile becomes a Photoshop.PNGFile.12 etc. etc. without even asking!

    I think this has something to do with your, and now mine with the bmpfile, problem.

    I'm going to run every graphic file association fix I can, where I still have the preview option and see what it comes up with.

    **** EDIT ****


    Right Mike, I think I've cracked it!! What I've done:

    Re-set all image file associations to default. (Maybe you'll just want to try this with one of your broken settings)

    I then added/changed this registry entry (As always would be best to export the key before you change it).

    Save this as a .reg file and merge (or manually add, of course!)

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\SystemFileAssociations\image\shell]
    
    [HKEY_CLASSES_ROOT\SystemFileAssociations\image\shell\edit]
    @="Edit"
    
    [HKEY_CLASSES_ROOT\SystemFileAssociations\image\shell\edit\command]
    @="\"Photoshop.exe\" \"%1\""
    [​IMG]


    (Some of the older members may possibly recognise the young lady on the left!!)

    Images now Preview with Photo Viewer and Edit with Photoshop. I don't really know if the Preview context entry is actually required as double-clicking the image opens it in Photo Viewer. Now all I need to do is switch Photo Viewer back to XNView!!
     
    #6 Elmer, Sep 12, 2011
    Last edited: Sep 12, 2011
  7. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    If it is only Tiff that is your major concern, Mike, how about the Control Panel - Default programs - Set associates.
    Scroll down to Tiff, and mark it. Select, top right, change program, and select Photo viewer or picture viewer from the drop down.
     
  8. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,045
    Likes Received:
    300
    Hi Guys

    I'll check this stuff out.

    I don't think this happened when Photoshop was installed.
    It has been on my computer from the start, and hasn't been updated or anything for a long time.

    I think this may have changed during a recent Windows update but I'm not sure.

    I seems to do this with Tiff and Png files.
    I haven't checked all of the formats but it works normally for jpegs.

    I'll try Elmer's fix and see what happens, it is only tiff files that I would really like to fix, pretty much everything I have is tiff or jpg.
    I can handle having to go to Open With for an occasional odd ball file.

    Mike
     
  9. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,045
    Likes Received:
    300
    Davehc.

    The problem I'm having it that there doesn't seem to be a way to set the action for the Preview command separate from the Open command.
    They used to be two separate actions that produced different results.

    Now what ever program I set as the default changes both of them.

    Mike
     
  10. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    I see. Just been experimenting with a couple of pictures. (jpg) First I tried Open with, and selected my default photo program (Corel ) Fine. Right clicked again and selected preview - Picture viewer. Subsequent tries produced the same. So maybe Elmers solution will do the trick for you
    There are quite a few instances of the registry fixes around the web. This one looks similar if you have fun doing it manually(LOL)
    Change the default image editor application, invoked from Windows Picture and Fax Viewer
     
  11. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    I'll add that running a 64bit system I actually ended up pointing the "Edit" entry to PS 32bit rather than the PS 64bit. I only did that because I have some plug-ins that I use quite frequently which, sadly, do not work with PS 64bit.

    Maybe one day :( ......

    If you wanted PS to be the double click open option then make that the "default" Program and change "Edit" to "Preview" and point it towards the Photo Viewer (what is the .exe name for that!!!) Answer = There isn't. It's shimgvw.dll! No wonder I couldn't find it!
     
    #11 Elmer, Sep 12, 2011
    Last edited: Sep 12, 2011
  12. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,045
    Likes Received:
    300
    Hi Guys

    I tried Elmer's fix.
    It gave my some new options on the right click drop down, I now get....

    Open

    Edit

    Edit with Image Ready

    Edit with Photoshop

    Preview

    Set as Desktop Background

    etc.

    I thought great now that I have a Edit with Photoshop button I'll just set the default to Picture Viewer and use the Photoshop button when I want to edit it.

    Unfortunately when I set Picture Viewer as the Default the "Edit with Photoshop" button disappears and it will only open with Picture Viewer.

    I'll check out Davehc's link.

    If that doesn't work I'll just set the default to Picture Viewer and go to Open With when I want to edit it.
    It's not a big deal, I just hate to let it get the best of me! LOL

    And it always worked the other way before.

    Mike
     
  13. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,045
    Likes Received:
    300
    Hi Again...

    OK this works alright.
    It's not the same but when Picture Viewer is the default I now have 2 choices.

    Preview at the top of the list and just below that Edit.

    The top button opens the image in Picture Viewer and the Edit button opens a list with Photoshop on it so I just click that an it opens.
    This is essentially the same as the old Open With list but at least it's at the top and I don't have to search for it every time.

    Mike
     

Share This Page

Loading...