Quickcam Orbit / Sphere MP issues

Discussion in 'Windows 7 Hardware' started by btangel, Mar 23, 2009.

  1. btangel

    btangel New Member

    Joined:
    Mar 23, 2009
    Messages:
    4
    Likes Received:
    0
    So I searched high and low for solutions on getting my sphere/orbit MP to work in win7 64.

    My specs are as follows:

    Core i7 2.66ghz
    EVGA x58 mobo
    6gb ram
    ATI 4870 1GB

    Win7 was able to find the drivers online, but I immediately noticed that under skype->options->video it shows nothing but black. I'm able to move the camera around via the webcam settings but no video at all. Unless the webcam is broken but I have to verify that on another machine... I ended up uninstalling the drivers, and just downloaded on from the logitech site. I was able to get the installation going in vista compatibility mode, but once it gets to the part where it tells you to plugin your webcam it won't detect it at all. So whatever I skipped that part, but the device is "unknown device" under device manager. So I tried to manually update the drivers by pointing it to the folder I extracted all the files to, but it won't recognize a driver under that... this seemed to work for other people with logitech cams but didn't work for me. :/

    So again I had win7 look for drivers online and the camera installed again. I then launched the quickcam utility app (again with vista compatibility) and now it tells me "webcam in use by another application". I did a fresh reboot and the same thing. I spent a good part of my weekend trying to figure this out. So I lay my problem to the rest of you folks. Hopefully someone can help me fix this.
     
  2. btangel

    btangel New Member

    Joined:
    Mar 23, 2009
    Messages:
    4
    Likes Received:
    0
    So I confirmed that the webcam works in XP.

    I reinstalled everything. Drivers + quickcam software. The mic on the webcam works! But in skype the video is just dark, and in the quickcam software it tells me it's being used by another app. This is probably a hardware conflict of some sort...but I can't figure it out. Will update if I find anything...
     
  3. petes457

    petes457 Senior Member

    Joined:
    Mar 26, 2009
    Messages:
    40
    Likes Received:
    0
    Good luck my friend. I really hope you find the problem, because I've wasted many many hours (in the double digits at least), reinstalling Quickcam, uninstalling other applications, trying various combinations, etc - with absolutely no luck on Windows 7 64-bit. I have the exact same situation that you do: Quickcam (11.5 or 11.9) says "the webcam is in use by another application, etc), Skype just gives a black square (ironically it will go through all the motions as if it's working - taking pictures, etc), MSN Messenger says it cannot connect to the webcam, etc. All the while the Device Manager says the camera is installed and working properly. (The webcam microphone DOES work properly.) Tried with two difference Quickcams (recent models) and they both work on Windows 7 32-bit and not on 64-bit. Just googling (forever), I believe that we are not the only ones encountering this on 64-bit. Extremely frustrating.

    Here is my earlier post on the subject:

    http://windows7forums.com/windows-7-support/3922-quickcam-win7-64-bit-wits-end.html
     
    #3 petes457, Apr 11, 2009
    Last edited: Apr 11, 2009
  4. lakephillip

    lakephillip New Member

    Joined:
    Sep 20, 2009
    Messages:
    4
    Likes Received:
    0
    Logitech Orbit MP Not working Windows 7 64-Bit

    Does Logitech really expect us to just accept an expensive piece of hardware to be discarded, because of new operating system?
    If that is their attitude I will refuse to purchase any other Logitech products.
    I have spent well over $1, 000 over the years with Logitech.
    If they just leave it at "we aren't going to support this operating system." I say I won't support their products or company. End of story.
     
  5. toxinhead

    toxinhead New Member

    Joined:
    Mar 25, 2010
    Messages:
    2
    Likes Received:
    0
    Also i have spent many pennys on logitech, and since they cant be bothered to update there software for the sphere, it shall be my last.
    Unless you guys wanna keep getting outdated Genus is the way to go (for webcams at least)
    Fin
     
  6. bassfisher6522

    bassfisher6522 Essential Member

    Joined:
    Aug 27, 2008
    Messages:
    4,878
    Likes Received:
    317
    Have you checked in your webcam software settings for the screen refresh rate or the anti flicker rate as WLM calls it. It's under the advance settings. Make sure it's set to 60Hz (North America). I use Logitech, WLM (windows live messenger) and Oovoo webcam software under windows 7 (32 bit) and all works just fine. I did find a 64 bit driver on Logitech's web site. See attached for location of advance settings anti flicker.
    View attachment 5898
     
  7. Fallen

    Fallen Senior Member

    Joined:
    Mar 20, 2010
    Messages:
    10
    Likes Received:
    0
    QuickCam

    Hi!
    I don't know is this proper post in here but i got my QuickCam Messenger WebCam Working with windows 7 Ultimate x32 when i downloaded latest Logitech software and when i installed software i searched driver for Camera from where i installed Software.

    I posted just because meny ppl seems to have problems with old webcams and i hope this solution works with others too.

    Have nice summer! \o
     
  8. LadyAshura

    LadyAshura New Member

    Joined:
    May 27, 2011
    Messages:
    4
    Likes Received:
    0
    I don't use skype, however since I use my webcam in other applications, when I installed windows 7 64bit, I let windows 7 install the drivers. I have been able to use my Logitech Orbit Sphere in MSN messenger, Yahoo Messenger, to take photos on facebook....etc without any issues. However, at the moment, I do not have the software installed. I am going to try the driver for windows vista (qc1051enu_x64) on the Logitech website first before I dig out the cd I have the older software installed on and see if that works with Win7 64bit.

    When I had windows 7 32bit installed, I had a problem getting the camera to work with the software. I actually stumbled upon a forum that had a fix for the problem. Install an older driver software. I did, and it worked just fine. I didn't even have to run it in compatibility mode. I could move the camera around and the software was fully functional with no issues.

    I just dug out my cd and found the driver software. I am not sure what operating system I downloaded it for, but I used it on Win7 32 bit with no problems, so I suggest doing a search for it if you want to give it a go (if I don't re-post with my findings yet).

    qc1110 that is, quickcam version 11.1.0

    ~LadyAshura
     
  9. LadyAshura

    LadyAshura New Member

    Joined:
    May 27, 2011
    Messages:
    4
    Likes Received:
    0
    Ok. Well, the software worked for me from the Logitech Website. I downloaded the Windows Vista 64 bit version. After downloading, I had to use compatibility mode and run it in Windows Vista Service Pack 2, and just for giggles, I also ran it as administrator for the installation file.

    It took a long time to install. Remember to install with the camera unplugged. After installing, it asks to reboot. So, do so or the camera won't work until you do. Before rebooting, I plugged in my camera. Then rebooted. Windows came back up and "installed the drivers" and now I am able to use the camera with the software just fine.

    So, I hope this works for you. Here is the download link from the Logitech website for the Logitech Quickcam Orbit / Sphere MP software for windows Vista 64bit.

    http://download01.logitech.com/web/ftp/pub/techsupport/quickcam/qc1051enu_x64.exe

    Remember, if you try to run the installation without compatibility, it will simply give you an error saying its not the right operating system or something. If you need any other instructions, don't hesitate to ask.
     
    #9 LadyAshura, May 27, 2011
    Last edited: May 27, 2011

Share This Page

Loading...