RAM HELP!!!

Disposal

Active Member
#1
Hello. I got a new laptop for christmas
its a toshiba satellite L750 and I got it for music production
Its x64 and it has 6gb ram but it doesn't seem to be using all the ram.
On my music program that I use (Renoise) It keeps having loud crunchy noises when there is too much reverb but on my mac which has 4gb ram it doesn't do that.

This is because it is using up over 75% of the cpu when on my mac it only uses about 40% when playing the same song.

On task manager it says it has 4gb cached memory and only 4gb is available.
I'm not that smart with ram but is my computer storing some of my ram? If so how to I get it back because I really want to be able to play concerts without loud crackly noises every now and then.
 


#2
With most laptops there is some ram allocated to be use by the onboard graphics which is why is shows up as it does in a windows environment. With a dedicated GPU you will not see this...ie gaming laptops. As for the Mac I have no idea because I haven't used one or know to much about them except that they're expensive...LOL.

Have you updated your Toshiba drivers to make sure that they are all the most current versions? Have you checked to see if there are any software updates with the software you use?
 


NoelDP

New Member
#3
Your Yoshiba probably has two sticks of RAM - one 4GB and one 2GB
I suspect that the 2GB is either not properly seated properly in its slot, or is faulty.
If you go into the BIOS, does that show 6GB, or 4GB? Did it ever show 6GB either in the BIOS or in Windows?
what shows up if you go to MSINFO32 - how much RAM is shown as installed there?
 


NoelDP

New Member
#4
....actually - forget about MSINFO32 - it doesn't understand anything above 3GB :(

Try downloading Belarc Advisor install and update it, and it will show what RAM is actually installed, in the Memory Modules section. If it shows only one stick, then you have a hardware problem - check the seating as a first priority.
 


Disposal

Active Member
#5
i forgot to mention that in control panel when i type in ram and click on "See how much ram is on this computer" It shows up as 6gb and on the music program it says 2 cpus
Should I still check on bios? So what do i do because this is really important

and its got an i5 processor if that helps
 


NoelDP

New Member
#6
How much of the RAM does the System page show as being usable?
There's a very good chance that you simply are looking at the amount actually in use - my system rarely gets above 2.5GB in use, unless I'm running VM's, even though I can have 20 IE windows, and anything up to 20 other (minor) apps in use.

There's a good chance that all you need to do is install a decent set of drivers for your sound card, or remove an interfering program.
 


Disposal

Active Member
#7
yeah I ran a driver scan on the program posted above but i need to register for all the programs I've tried. Does anyone know of a driver installing program that is actually free and you don't have to register for?
 


NoelDP

New Member
#8
Go to the hardware manufacturer's website and check there - if you need to know what hardware you have, check Device Manager, or your manual
 


Disposal

Active Member
#9
ok so what driver is for ram because I don't want to download all of the drivers it will be too big
 


#10
It's not RAM you need drivers for - it's your Sound card (and possibly Video as well).

If you open Device Manager - what Sound devices are shown?
What Display Adapter is there?
 


#11
Try this. Go to start orb and click, in the search field type "system configuration" with out the quotes. Then select the boot order tab at top and then select advanced options. In that that window you can tick the box for maximum memeory.


View attachment 18053
 


#12
sound:
contextant smartaudio hd
nvidia high definition audio

display adapter:
nvidia geforce gt 525mb
 


#13
I ticked the maximum memory but when i rebooted the computer only had the 2gb ram stick activated and on the music program it only said 1 cpu intead of 2 how do i change it back ahahahahhhhhhhhh
 


#14
hey its working now i think. I did the maximum memory thing again and held down the up button until it got to 6144 and then restarted and the music program seems to be working and only using 40% of the cpu
 


#15
I knew you would figure it out....we have to leave you somethings to figure out for yourself....hahahahh....

Seriously; glad you finally got it working....good job.
 


#16
GSSaHasdgierfhhuj this is really getting on my nerves.
It keeps resetting the max memory thing.
I make all boot settings permanent and it does nothing
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top