RAMs

#1
Hello,

I just purchased HP g6 Laptop specs as follows:
Intel i7 3612QM 2.1 GHz
4 gigs RAM DDR3 (1 chip)
AMD Radeon HD 7670m 1 gig dedicated + Intel HD 4000 (Dynamic Switchable Graphics)
windows 7 home basic 64 bit
500 gigs HDD

the problem as follows, my system information says: RAMs is 4 gigs (2.41 usable), the task manager also uses the 2.41 usable giga of RAM, my BIOS says that 4 giga of RAM installed, and other system information applications reads the 4 giga RAM, is there a way to fix this?

I hope it is not repetitive thread, and I would appreciate a quick resourceful feedback.
thanks.
 


zvit

Honorable Member
#2
Welcome to the forums.

First, make sure that your Windows is actually x64 and not x32 (x86) Properties of "My Computer" will show you this.
If it is, it probably is the AMD Radeon HD 7670m 1 gig that is "stealing" this RAM.

Read the post from GeNeo here:
RAM 4GB, only 2,94 usable - Windows 7 Forums

One of two things:

1. Your graphics card is ussing 1 GB of address space, but not physical RAM
2. Your graphics card is using 1GB of physical RAM instead of having its own

The first is more likely. I'd be pretty surprised if your computer BIOS didn't have a memory remap feature in the BIOS so you could actually use all 4GB. In that case, your computer needs address space, but not physical RAM, to communicate with your graphics card. If that address space is located below 4 GB, it is 1GB of RAM that gets wasted. Memory remapping allocates the 1 GB of address space the graphics card needs above 4GB, so the full 4GB of address space for your system and programs can be mapped to the 4GB of physical RAM.

So boot to your BIOS and see if there is memory remapping (or sometimes called a hole) option to enable.
 


#3
well, my BIOS just give me information, and nothing else, in the configuration tab, the only thing disabled is the virtualization technology, :) anyway. and i am sure that windows is 64 bit.
Sys Info.png
 


#4
Memory Monitor.png

also this image might define other things as well :)
btw, i really really appreciate your time :)
 


zvit

Honorable Member
#5
Yes, you have x64.

Check the following...

Press Windows Key + R and type msconfig into the run command box.
On the "Boot" tab, click on advanced options.
Make sure the box labelled "Maximum Memory" is NOT ticked.
If it is, untick, save and restart.
 


zvit

Honorable Member
#6
You can see in the picture that is "Hardware reserved" that is stealing the RAM. We have to figure out if it's the Card or something else. I'm looking into it.
 


#8
the boot window thingy got the Max Memory ticked, I unticked, restarted and...
New Sys Info.png
New Monitor.png

your analysis? :D
 


zvit

Honorable Member
#9
Look great!
 


#10
then it is fixed, Thanks zvit, thank u million times, u made my day :)
i really appreciate your time and effort :)
have a wonderful day sir :)
 


zvit

Honorable Member
#11
You too. You're welcome.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.