Randomly disconnecting ... (Home network, no internet access)

Discussion in 'Windows 7 Networking' started by SmukY, Oct 31, 2009.

  1. SmukY

    SmukY New Member

    Joined:
    Oct 31, 2009
    Messages:
    8
    Likes Received:
    0
    Hello to all. I'm new on W7 forum.

    The fix of halcion1's didn't helped for me (it did, but not for a long) I still have problems with disconnecting from internet (Home network > Network access works, but no Internet access). I've already unticked IPv6, disabled/deleted the Bonjour service/map, disabled the computer's allowation for turning off the Atheros L1 Gigabit Ethernet 10/100/1000Base-T Controller (Integrated network adapter on Asus P5K motherboard) for power saving too, It's even updated on last version. All those actions didn't prevent the disconnectings from internet. Right now while I was typing this text I was again disconnected from internet.

    [​IMG]

    My computer is wired to TP-Link TL-WR642G router, router is wired to my ISP optic modem. On router are connected two notebooks (wireless) and they're working perfectly without internet disconnections, they both have Win XP SP3.

    My computer specs are:
    C2D E6600 2,4ghz processor
    nVidia GeForce 9800GT 1gb
    4gb of ram
    Asus P5k (Atheros L1 Gigabit Ethernet - integrated network adapter)
    Win 7 x64 (7600 build)

    Only disabling and enabling the network adapter temporarily reestablishes the connection to the internet ... then's just a question when will be again disconnected. While typing this text, I was twice disconnected from internet, which makes me insane.

    I will appreciate any answer on this ... and sorry for my bad english. I'm so mad that I neither can't check my english grammar and spelling ...
     
  2. Liquidz0R

    Liquidz0R New Member

    Joined:
    Jun 9, 2009
    Messages:
    12
    Likes Received:
    0
    Hi man, I'm having the exact same problem.

    I had the RC version of Win7 but hoped it would have been fixed in the retail release but apparently it hasn't. Anyway, as far as I know, the problem lies within the way you connect your PC to the internet.

    I have the same setup as you: Modem for getting DSL signal -> Router -> PC.

    Most likely, when you plug your PC right into your Modem it will work, because it works for me and a lot of other ppl it seems. It's only when you connect your modem to a router and connect your pc to that router that the problem occurs.

    Here's a topic on the official Microsoft forums, where a representative answers/suggests a couple of things:
    Constant disconnects

    Apparently updating firmware might help, but seeing how many people have similar problems I doubt it's going to resolve it, but it never hurts to try when you have time for it right?

    Anyway, it's making me go crazy as well, because I can't do anything properly:
    - Downloading larger files -> gets interrupted
    - Playing a game -> time outs
    - Browsing -> once every few loads I have to wait for about 20-30sec to finally get to see a page/reload a page properly
    - Steaming -> What did you think? long interruptions and so on
    - Chat -> reconnecting to the service every few minutes

    All in all, Win7 is great but seeing the internet plays a very important role in my life I'm not sure what I should do myself. Probably going to try and upgrade my firmware, if that doesn't work ... hope for a quick fix from microsoft and otherwhise it's back to vista for me (at the moment).
     
  3. SmukY

    SmukY New Member

    Joined:
    Oct 31, 2009
    Messages:
    8
    Likes Received:
    0
    I think I found a solution ... I've checked my Event viewer yesterday, and I found a lot entries of error AtcL001 (there was over 100 entries for this error, almost every minute. Error was connected with my network adapter Atheros L1 Gigabit Ethernet Controller. I was shocked.

    [​IMG]

    I've googled after AtcL001 and even second result has found a thread where someone have same motherboard as has I and same problem on even same OS.

    Solution was in the last post - disable the checkslum offload in Network adapter's properties. I didn't found checkslum, but i found a task offload, so decided to I disabled task instead of checkslum (Local Area Connection > Properties > Configure > Advanced > set Task Offload value off). From disabling i didn't experienced any problems, even event viewer doesn't have any new entries about AtcL001, so i pressume that's the solution. I don't want mark this topic for answered yet because I want to be sure first (i think some three days will be enough for ensurement)

    Now there's other thing which worries me - this Task Offload.

    Network adapters with appropriate NDIS 5 (and later) miniport drivers can increase the system performance by supporting hardware offload of Transmission Control Protocol/Internet Protocol (TCP/IP) CPU-intensive tasks. For example, with TCP/IP checksum offload alone, up to 30 percent performance gain in CPU utilization has been seen in testing at Microsoft. The NDIS interface and the TCP/IP transport have been enhanced to allow miniport drivers to indicate hardware support for performing.

    Highlighted part. Now I just worry if processor will not fell on it's "knees".

    Knocking on the wood ... if i will experience any problems i will post here again. Or instead of posting I will install XP SP3 back.
     
    #3 SmukY, Nov 1, 2009
    Last edited: Nov 1, 2009
  4. Liquidz0R

    Liquidz0R New Member

    Joined:
    Jun 9, 2009
    Messages:
    12
    Likes Received:
    0
    Wow, I've been trying several things since I first posted here.

    It occured to me that, while my internet was behaving weird and I was surfing to my gateway/modem (192.168.1.1) to check my settings once again, the interface I got was not the one from my modem but the one from the router which is in between my computer and the recieving of the internet connection.

    That got me thinking ... I kind of guessed/figured it would be the modem & router having a fight over the connectivity with my ethernet adapter. The reason why is explained above (changing webinterfaces on same address). Now, at first I thought it would be a DHCP issue, since DHCP gives my computer a network IP to work with.

    As my modem provides internet access I figured I should enable DHCP on it, and disable it on my router. After looking into it I actually found out DHCP was already turned off on my router, so that couldn't have been the problem. Then I started thinking once again, because I was curious what made the webinterface for my modem change to the one for my router.

    I ended up modifying the gateway of my router (changed it to 192.168.1.2). I also changed the DHCP lease time on my modem to 3hours or so (it was way too short imo, only 3mins by default) and enabled the "Auto-IP" function on my modem as well.

    After doing those couple of things I've been free of any disconnects. So basically the only things I've done are:

    Router:
    - Changed the default gateway IP from 192.168.1.1 to 192.1.2
    - Checked if DHCP was on or not (was off already, didn't change anything)

    Modem:
    - Changed DHCP lease from 3mins up to 3hrs
    - Enabled "Auto-IP" function on top of DHCP

    Basically, that did the trick for me. I'm not sure if it will stay stable since I'm only writing this about 10hrs after having changed it but being online for 10hrs straight without a DC is an enormous improvement over 1-5mins before getting disconnected to say the least.

    Also, what might be interesting to know is that I disabled all of my Checksums in my Ethernet adapter properties (advanced tab). I'm not sure if this helps me or not, I still have to find out but first I'm going to enjoy a little time with my stable internet :)

    *EDIT*: I forgot to say something. I had no problems in XP nor Vista with my setup (before altering it) but I do think it has something to do with Win7 network processing or something. To put it simple: I think that Win7 gets confused (you might say it's smarter than Vista/XP) when it sees 2 devices trying to deliver the same IP to the same ethernet adapter. In XP/Vista it just picked 1 but I do think Win7 can't make up its mind and therefore tries swapping in between ... much like a child not knowing what to pick.

    I might be wrong though, I'm no network engineer but I really can't think of any other reason why Win7 would behave the way it does (while knowing Vista & XP don't behave like that). Hope it helps someone :)
     
    #4 Liquidz0R, Nov 3, 2009
    Last edited: Nov 3, 2009
  5. SmukY

    SmukY New Member

    Joined:
    Oct 31, 2009
    Messages:
    8
    Likes Received:
    0
    Well I can confirm that disabling the task offload in network adapter properties solved my problem. In past three days my Internet connection didn't dropped and now it works as it's supposed to. Anyway thanks for the help.
     
  6. Liquidz0R

    Liquidz0R New Member

    Joined:
    Jun 9, 2009
    Messages:
    12
    Likes Received:
    0
    I completely agree.
    However, I'm not condemning windows 7 in any way (not saying you assumed that I did), I'm just saying it reacts differently to certain settings than the WinXP/Vista environment does. I actually think Windows 7 is smarter to be able to differentiate between two devices when they are addressing the same gateway. I think (again, not sure, I'm not expert) WinXP/Vista just picked the first value to go with and never looked back at the situation while windows 7 does look back and tries to modify certain events (resulting in a bad outcome in this case).

    The cause of this problem is most likely not Windows 7, however windows 7 does bring light to an existing situation of conflict which hasn't been brought up by other OSs before.

    I absolutely love Windows 7 though, it's so much more leightweight than Vista, has better 64bit compatibility than XP and all in all looks way better too. I've never been a vista fan because of the ram requirement to run it.

    Lastly, I know that buying a new router could have solved my problem but I've only bought my modem half a year ago, and it cost me more than enough for me to try and find a way around the problem instead of spending money on something that I might not need after all.
     

Share This Page

Loading...