Razer Barracuda sounds card driver issues.

IanG

New Member
#1
Hello everyone, Ive recently installed and managed to update nearly all of my hardware. Im comming from a Vista 32bit OS to Windows 7 64bit... So nearly everyone needed to be changed out.... All has gone flawless except for my damn sound card. Im running a Razer Barracuda AC-1 Gaming Audio Card. When I tried to install the 64 bit driver windows gave me error about it not being digitly signed and it wouldnt install. I disabled the need to digital signing but windows has either flagged this driver as "bad" or just wont cooperate with me. I can currently use my onboard sound card... If that means anything to you guys.

As you can see, the driver listed as installed is a "32bit" driver... Any attempts to install the 64bit driver has resulted in windows telling me no...
My specs are as followed, Any help would be greatly appreciated.


OS Name Microsoft Windows 7 Ultimate
Version 6.1.7100 Build 7100
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name IANS
System Manufacturer MICRO-STAR INTERNATIONAL CO.,LTD
System Model MS-7388
System Type x64-based PC
Processor AMD Phenom(tm) 9950 Quad-Core Processor, 2600 Mhz, 4 Core(s), 4 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. V1.7, 6/12/2008
SMBIOS Version 2.5
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = "6.1.7100.0"
User Name Ians\Ian
Time Zone Pacific Daylight Time
Installed Physical Memory (RAM) 4.00 GB
Total Physical Memory 4.00 GB
Available Physical Memory 3.07 GB
Total Virtual Memory 8.00 GB
Available Virtual Memory 6.97 GB
Page File Space 4.00 GB
Page File C:\pagefile.sys
ATI Radeon HD 4870 X2

SOUND
Name High Definition Audio Device
Manufacturer Microsoft
Status OK
PNP Device ID HDAUDIO\FUNC_01&VEN_1002&DEV_AA01&SUBSYS_00AA0100&REV_1001\7&9B6CB&0&0001
Driver c:\windows\system32\drivers\hdaudio.sys (6.1.7100.0, 342.00 KB (350,208 bytes), 4/21/2009 9:15 PM)

Name High Definition Audio Device
Manufacturer Microsoft
Status OK
PNP Device ID HDAUDIO\FUNC_01&VEN_10EC&DEV_0888&SUBSYS_14627388&REV_1000\4&1395493B&0&0001
Driver c:\windows\system32\drivers\hdaudio.sys (6.1.7100.0, 342.00 KB (350,208 bytes), 4/21/2009 9:15 PM)

Name Razer Barracuda AC-1 Gaming Audio Card
Manufacturer Razer
Status Error
PNP Device ID PCI\VEN_13F6&DEV_8788&SUBSYS_09101A58&REV_00\4&2966AB86&0&10A4
I/O Port 0x0000E800-0x0000E8FF
IRQ Channel IRQ 3
Driver c:\windows\system32\drivers\cmudaxp.sys (5.12.1.8, 1,014.00 KB (1,038,336 bytes), 3/26/2007 7:13 PM)
 


#2
I have had this problem for quite a while, myself.

I'm probably going to do a fresh install of the RC version of 7, and from there I will probably disable device signing and try the vista drivers again. I hope it works.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top