RDC/RDP Not Working as Expected - ssh Tunnel from WinXP

Discussion in 'Windows 7 Networking' started by Win7Tester, Dec 22, 2009.

  1. Win7Tester

    Win7Tester New Member

    Joined:
    Dec 22, 2009
    Messages:
    4
    Likes Received:
    0
    I am wondering if Win7 introduced some odd kinks to the way remote desktop connections work?

    My objective is to securely access my Win7 desktop at the home office from anywhere via the public internet. Although I will have my personal notebook computer with me 90% of the time, as a lesser objective, it would be nice to run whatever client or tools it requires from a thumb drive.

    My config is Windows 7 Ultimate on a home office server. I am using a WinXP Pro SP2 as a test client. I do have a static IP address assigned by my ISP and port forwarding on my router appears to be working fine (see below). For reasons beyond my control, my notebook client (WinXP SP2) cannot be upgraded to SP3 at this time.

    My intent was to do the following, using this as my outline:
    http://theillustratednetwork.mvps.org/Ssh/RemoteDesktopSSH.html
    I am using copenssh on my Win7 host
    I am using putty on my WinXP client
    I had Zonealarm installed on the Win7 host as this was the practice we used on WinXP (and had the Windows firewall turned off).

    For testing purposes, even though the two systems currently are connected to the same LAN, when testing, I am using the publicstaticip:port. It is a little slower - but this should simulate my objective.

    I had a few problems getting the ssh tunnel to establish but once I turned off the firewall on the Win7 host - no problems. I can manually establish the ssh session from the client to the Win7 host, login, and do some basic navigation to prove that port forwarding ok.

    What is not working is getting remote desktop to work. Once I establish the ssh tunnel, I start the remote desktop client and have used "localhost:port#", "127.0.0.1:port#", "127.0.0.2:port#" (replacing the port number with various iterations of putty tunning configs I have tried).

    I get the same error every time: "This computer cannot connect to the remote computer".....

    I CAN connect from the WinXP client to the Win7 host over my LAN using its local ip address - no problems. So it boils down to something about rdp coming in over the ssh tunnel that Win7 just does not like.

    Suggestions?
    Is there a better way to estblish a secure connection get remote desktop control? I considered VNC but figured the native Windows tools "should" work.
    All of the examples where others seem to have been successful with this appear to be older threads that do not include Windows 7.

    Any help would be appreciated.
     
    #1 Win7Tester, Dec 22, 2009
    Last edited: Dec 22, 2009
  2. Win7Tester

    Win7Tester New Member

    Joined:
    Dec 22, 2009
    Messages:
    4
    Likes Received:
    0
    Well, FWIW, I gave up on the whole MS Remote Desktop connection and went back to VNC.

    Tunnels over ssh no problem - not sure why rdp is not working over ssh.
     
  3. kenw232

    kenw232 Senior Member

    Joined:
    Dec 15, 2009
    Messages:
    20
    Likes Received:
    0
    For what its worth I tunnel RDP over SSH perfectly fine on Windows 7 Ultimate 64 bit. Nothing unique or special has changed from what I can see. Just port forward 3389 as usual.

    For testing from the desktop do a telnet whatever.local.ip.address 3389 and see if it at least will go through the tunnel to rule out a port forwarding problem as opposed to a server availability issue on the other side.
     

Share This Page

Loading...