RDC (Remote Desktop) SLOW!

#1
Hi all,

I have the RC 7100 build of W7. Every night I need to RDC into 12 different servers to do some backups. This process works quite well in Vista, XP, etc, however in W7 it is painfully slow. If only one RDC window is open, there is about a 2 second delay on any keystrokes or mouse clicks, and I have to refresh the screen if I minimize it then go back in (it's black otherwise). The more windows open, the longer the delay. It gets to be almost 8 seconds of a delay if all 12 windows are open. Again, windows vista didn't have this issue.

What can I do to improve the delay with RDC?

Thanks!
 


#2
Hi there
try and reduce the background resolution. Say from True colour to 15 bits.
This will reduce the amount of data being sent -- especially if stuff has to be sent from a HOME or slow Network ISP where upload speeds are often painfully slow.

Disable features such as Bring sound from remote to local and switch off the Disk mapping unless you really need it.

A better mechanism than RDP might be to create a VPN. I think in this case data is much more "optimally" transmitted via the network.

If you are just "Syncing" files etc then a far far better solution (and faster) is to use a decent FTP program -- bear in mind that the limiting factor will be your UPLOAD speed through any ISP or network.

Another solution would be to set your servers up to schedule backup jobs to be run nightly - rather like the Linux CRONTAB feature. Most decent backup software will let you schedule jobs and give you the choice of "Full" or incremental" backup.

Whilst not solving your RDP problem I'd suggest that using an "Automated" backup solution like I've outlined is far better.
At the end of the job you can get it to email you the result or the log so you wouldn't even have to log on to the servers to check whether the jobs ran successfully or not.


Now if you have some really smart software it could even send you text messages. But that's a bit more "adventurous and costly".


Cheers
jimbo
 


Last edited:
#3
try and reduce the background resolution. Say from True colour to 15 bits.
This will reduce the amount of data being sent -- especially if stuff has to be sent from a HOME or slow Network ISP where upload speeds are often painfully slow.
Thanks, I'll try that
Disable features such as Bring sound from remote to local and switch off the Disk mapping unless you really need it.
I'll try this too!
A better mechanism than RDP might be to create a VPN. I think in this case data is much more "optimally" transmitted via the network.
This -is- over a VPN, all 12 locations as well as my bosses and my homes are VPN'd together.

If you are just "Syncing" files etc then a far far better solution (and faster) is to use a decent FTP program -- bear in mind that the limiting factor will be your UPLOAD speed through any ISP or network.

Another solution would be to set your servers up to schedule backup jobs to be run nightly - rather like the Linux CRONTAB feature. Most decent backup software will let you schedule jobs and give you the choice of "Full" or incremental" backup.

Whilst not solving your RDP problem I'd suggest that using an "Automated" backup solution like I've outlined is far better.
At the end of the job you can get it to email you the result or the log so you wouldn't even have to log on to the servers to check whether the jobs ran successfully or not.


Now if you have some really smart software it could even send you text messages. But that's a bit more "adventurous and costly".
Unfortunately, the businesses are pharmacies, and the software requiring backing up has it's own archive procedure that must be run from a command prompt. Also, every session of the software must be closed on each workstation, and sometimes people leave it open, so I need to check the sessions on the server. Additionally, there is other custom software runs on the server that mimics a session, which must be closed prior to the archive and re-opened after. No automated tool will perform these tasks with any reliability. The last employee who I replaced had been using a method that he thought had been working, however hadn't for over 6 months.

Thanks for the reply!
 


#4
RDP Slow - Similar Problem

I'm experiencing the same problem, same W7 build (7100). When I use RDP to remote manage, it's way slow. On Windows 2003 Servers it's only somewhat slower than previous version of Windows (2-3 second delays). On Windows 2000 Servers, it's painfully slow. When connected via RDP, the server Task Manager shows the termsrv.exe process using 80-100% CPU. So something's not equal with the RDP feature across Windows versions (XP/Vista/Windows 7).

I've already tried stripping down the RDP options, to no effect. I'm connecting over a 100Mbps LAN, so I don't think color depth options should factor in, anyway.

If anyone comes up with a reason or fix, I'll be watching.
 


#5
Hi there
I can't remember it now but there was a fix to speed up the up / download performance from torrents and network performance generally by changing the default nr of connections in the TCPIP stack.

I'm not a network guru - so I can't remember exactly but there was something you could change as the default stack limited the number of connections or threads. Changing the value from the default improved my network performance considerably but I can't remember what I did unfortunately. Googling should help you here.

Cheers
jimbo
 


#6
Thanks for the responses, however the issue still persists after attempting all suggested resolutions.

I've noticed that the connection to my one XP server (not really a server, more of an app server on a workstation) is not nearly as slow as the connection to the other 11 Windows 2000 server connections.

This is not a network issue, as everything else runs smoothly and I never had this issue before Windows 7.

Any other suggestions? I hate rebooting into my Vista install just to RDC.
 


#7
its wierd, with Windows 7, my RDP has never went so fast. Did you install the right certificat? Maybe Windows has some problem with it. So it slows your connection.
 


#8
Hmm, I'm using a folder of rdc connections that I saved from my previous vista install. Could that be the problem? If not, how do I check the cert?
its wierd, with Windows 7, my RDP has never went so fast. Did you install the right certificat? Maybe Windows has some problem with it. So it slows your connection.
 


#9
Yes it could be your problem, but I must admit, when I did my RPD test, I was connecting to my laptop (with vista of course), and I received an error telling that my certificat wasn't signed by authoritive compagny (like VeriSign), then, I had the choice to choose which certificat to install. Then I installed the first one I saw, then it was telling me that certificat wasn't secure, but whatever, in the end, the certificat was now install on my computer, if you didn't get any warning while trying to connect, check it out in your option. But I think it's only good while connecting to Vista or another Windows 7.
 


#10
Well, I removed the old rdc connections and made all new ones in 7, same thing. Any othere recommendations?
 


#11
same for me

I'm having the same issue. I RDP into several Win2k virtual machines, as well as physical machines, and it slows to a crawl. The termsrv process takes up almost the entire CPU. I've tried to disable all bells and whistles, but it is still incredibly slow. If I RDP in from a XP box I get a snappy machine.
 


#12
We have same issue in whole Windows Support team here

Since now i was using build 7000 but now i changed to 7100 and i am in same situation like me coleagues. But i did not beleive them since i change build to new one. Yes RDP in is very very slow to all W2k Server systems. we have here like 1500 so we have a lot to test on :eek:) it is sofwtare issue and reducing of anything did not help.

Fido

Build 7000 RDP to w2k is normal and fast
Build 7057 RDP is bloody slow to w2k servers
Build 7100 same like 7057 not working

not happy from it but i will have to go back to 1st build 7000 because this is my primary OS and i like it. i do not want to go back to XP or Vista.
 


Last edited:
#13
One thing I could only tell you, Microsoft added since Vista a lot more security features, but with Windows 7, I don't know if it was there with the 7000 build, the certificate features, Windows maybe tries now to do a connection with certificate with a computer that don't even know the existance of a such feature, I know you probably look at it already, but make sure all security measures are gone, close Windows Firewall/Windows Defender, Right-click on Computer, Remote Control, if you got a router, try to do a DMZ with your Computer, did you try to connect to another computer inside your LAN, what about VPN (if you are using it) make sure everything are set with the right protocol, if you are using VPN, if you map a network drive to your computer and then you do a file transfere, is it slower than normal? If yes, the problem is maybe the VPN, otherwise, you must find something about the RDP, I didn't look at it, but maybe Windows changed the port number for it, maybe it's still using 3389 port, but as a secondary one while the primary one is blocked.

You can try to change your listening port, follow these instructions :
http://www.mydigitallife.info/2006/12/04/modify-and-change-remote-desktop-listening-port/

Good Luck
 


Last edited:
#14
you are not reading?

you are not reading?

i wrote that it is working in pre-beta version and in build 7000


it is not working in build 7057 and 7100


so what about ports? routers? firewalls it is same.

this is just new bug...
 


#15
Well go back on your old version, was just trying to help you with 7100, you may even go back to Vista, it will completly fix that little problem, just stop be impudent.
 


#16
I'm having the same issue. I RDP into several Win2k virtual machines, as well as physical machines, and it slows to a crawl. The termsrv process takes up almost the entire CPU. I've tried to disable all bells and whistles, but it is still incredibly slow. If I RDP in from a XP box I get a snappy machine.
Don't know if this has been resolved, but I had exactly the same problem (only to Win2K machines) and this solution worked for me:
Remote Desktop slow problem solved

Further, I applied the latest round of Windows 7 updates and RDP went all slow on me again. Repeated the above solution, rebooted, and now all is good again :)
 


Last edited:
#17
Don't know if this has been resolved, but I had exactly the same problem (only to Win2K machines) and this solution worked for me:
Remote Desktop slow problem solved

Further, I applied the latest round of Windows 7 updates and RDP went all slow on me again. Repeated the above solution, rebooted, and now all is good again :)
Thanks for the tip, however my problem still persists. The first RDC window open is just fine, then the second slows down to about a 1 second delay on keystroke/mouse click, then the third window slows to about 3 seconds, and so on and so forth. For now I'm just rebooting into my Vista install and doing my work that way. I'd love for Microsoft to secretly come out with a fix for this in a patch soon, as I have auto updates on.

Windows 7 is awesome...but this is a necessity, and shouldn't be causing issues.
 


#18
I've found a temporary solution from another blog, it is not a permanent solution. Microsoft needs to address this issue before RTM.

Download 7zip.
Download an old version of Remote Desktop Here: Windows XP: Remote Desktop Connection Software Download
Using 7zip Extract msrdpcli.exe to a folder. (this is the 32b version)
Using 7zip Extract msrdpcli.msi to a folder. (this is the 64b version)
Using 7zip Extract data.cab to a folder.
Rename F1059_mstscax.dll to mstscax.dll .
Rename F1060_mstsc.exe to mstsc.exe .
Rename F1061_mstsc.chm to mstsc.chm .

You can now place those 3 files wherever you want, and run mstsc.exe to launch the old client.


Now I just need to figure out how to make all RDC connections default to using this old version instead of the new version. It doesn't want to keep my settings that I set in "open with".
 


#19
one thing i noticed about this - connecting to a 2000 server caused my internet to transmit at 100%, its all rdp and destined to the server.

Causes it to go very slow, as its using all my internet.
 


#20
Anybody know of any pending updates to the 7 RC that fixes the bandwidth issue when connecting to Win2K machines?
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top