Read Only on all Folders, Take Ownership, CMD attrib don't work. Losing my mind

#1
Hi,

I have been on the edge of chucking my computer out the window for hours, and the only support I get from colleagues in my masters program is "Get a mac!"

Anyway, yesterday I was working on something in CodeBlocks and when I went to build my project, I got stuck in a loop of "this project has not been built yet, want to build it now?", which has NEVER happened to me before. I looked at the folder, and it had the "Read Only" filled in with a blue box.

I tried to uncheck it, and apply. That didn't work. I tried changing User settings for the folder, which didn't work. I followed the cmd window advice (attrib -r +s C:/ etc etc), and that didn't work. I downloaded, installed and ran "Take Ownership", right-clicked the folder, and 'took ownership' with reported success from the command window, but still it cannot build any of my projects, and read-only is still filled in.

I noticed this plight of Read Only has now spread to each and every one of my folders. I have been sobbing as each and every attempt to get my computer back to its old working self has failed time and again.

I don't remember installing any Windows updates, but it's possible I did. No changes have been made to my install of any program for over a week, so I don't know what is causing this plague.

Windows says I can't get direct help from them without paying $50, and I am not sure why I have to pay to have them listen to my problem, when it's probably something faulty within Windows, itself.

Can someone please please help me? I am really losing it, here.

---B
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
The blue box seems to apply to folders only, but does not mean files in the folder are read only. Many of my folders exhibit the same indication.
 


#3
It would be nice if that were true, but it seems that programs, like the Code Blocks IDE can't build any projects (which requires making a new folder).

It's ridiculous, and wasn't the case days ago.

Anyone have any suggestions?
 


kaos

Senior Member
#4
try my program i wrote, its safe i promise

steps are!

drag the folder onto the command promt screen , the path should be auto entered
hit enter
type your username that you are logged in as
hit enter
type grant
hit enter

see if you have access

View attachment Permissions.zip
 


#5
Thanks for the program, but it still doesn't work :(

I tried to gain access to my top directory, then my user directory, and I didn't get any errors, but then it didnt get rid ofthe read only thing either :( :( :(
 


kaos

Senior Member
#6
are u sure the accounts is and administrator or standard account
 


#7
I only have one user: me. I am really stuck here .. :/
 


#8
Any other ideas? I am really lost here, and I can't compile anything anymore :(
 


kaos

Senior Member
#9
you can right clic the folder, properties , click security, click on your name, check what items are ticked and also check what user group you are in

start >search box type > netplwiz > click on advanaced tab > groups > check if you are in the adminsitrator group
 


#10
My account says users. I enabled the administrator level through cmd and logged in as admin. I tried to uncheck read only and got the same results. I tried doing take ownership as well as attrib in cmd to no avail. I even booted in safe mode to see if any process was at fault, but still can't compile projects in my IDE-- the read only box is still blue.
The next thing I tried was going to a restore point, but that failed because it was unable to extract some file or other ( the path was so long it didn't wrap in the error message)

Any ideas? I'm in a miserable state here. Thanks for trying and replying!!! I'm desperate for a fix
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top