ReadyBoost Flash Drive...Stumped

Discussion in 'Windows Vista Help and Support' started by The007Fanatic, Feb 10, 2007.

  1. The007Fanatic

    The007Fanatic New Member

    Feb 10, 2007
    Likes Received:
    Hi, this is my first time vising these forums but I wanted to see if anyone has experienced anything like this. I'm running Vista Home Premium and this behavior has occurred on both RC1 and this final release. Basically I'm stumped and don't have a solution for myself. I have a PNY flash drive and a Corsair flash drive. The PNY is the only one eligible for ReadyBoost. When the PNY is plugged in I get the "Safely Remove Hardware" icon in the tray but never get that when I plug the Corsair in. If Readyboost is enabled on the PNY and I reboot the system, the readyboost file disappears completely but I can still access the USB drive and re-enable it. If I shut down, hibernate, or sleep the system with ReadyBoost enabled, when I return to Windows the next day or whatever the safely remove icon still shows and so does the PNY drive in Explorer. But if I try to open the drive it says "I need to format the drive before I can use it." Only I can't format it as it fails every time and my only option is to Safely Remove the drive and plug it back in. Doing that brings back everything including the readyboost file. I've tried "optimize for quick removal" and "optimize for performance" in device manager and nothing changed. However if I don't have readyboost enabled on the drive, it seems to be readable and everything even after a shut down or hibernation. I'm just wondering if there is a compatibility issue with my drive and Vista and if I bought another USB drive that was readyboost compatible would it do the same thing to me? I just want to keep the USB drive plugged into the back at all times and not worry about it if that's at all possible.
  2. josh_rain

    josh_rain New Member

    Jan 23, 2006
    Likes Received:
    This is a tricky problem. Hopefully I can assist you with it. I've only had one jumpdrive and so far its worked great. Keep in mind I only support win2k and no other windows OS, heh.

    Ok so, one works and the other one doesnt even have a chance. First lets address teh Corsair flash drive. Have you used the drive in another machine? If so then try to check the manufacturers website and see if there are driver updates for it for Vista or contact their tech staff. I'm sure they would be willing to provide links or tell you if there are drivers available for it or not. If it doesnt work then there is a good chance the drive is fried. Some companies online will do diagnostics on it and if possible recover the lost data. Otherwise, get and RMA from Corsair and return it to get a new one. Just tell them you bought it a few weeks ago and now its fried :p

    Next your PNY.

    1: The reason for the explorer window of the drive opening is that window slike to keep track of what windows were open during a crash. funny how linux doesnt do that ;-) So if you have the window open or anything else open on the screen, it will automatically open that spot back up for you so you dont lose your place. Or so ive read/seen/been told.

    Check PNY for support with that drive. It doesnt look like software is available for it but you could try to reinstall the driver manually. Sometimes that will help. Honestly im not too sure about your problem. its one of thsoe things where I need hands on with it to tell you.

    2: this is an important one. NEVER format your jump drive. You should never have to do that unless you just want to whipe the data from it and even then shift+delete will work. The reasong for safely remove hardware option is because it needs to write the cache to the drive. Sometimes data can be lost if things arent removed safely.

    Post any comments or question.


Share This Page