readyboost not showing in services.

Discussion in 'Windows Vista Help and Support' started by alfrocks, Dec 10, 2008.

  1. alfrocks

    alfrocks New Member

    Joined:
    Dec 10, 2008
    Messages:
    4
    Likes Received:
    0
    I just found out about the readyboost function in vista but after searching on the web for two days I have still not found my answer. I am running windows vista home premium. I have a usb stick that meets the requirements for readyboost, sorry I cant remember the brand of it right now. Anyways when I plug it in I dont get the option of using it as speeding up my performance.

    The most frustrating thing is that everyone says turn it on in services, I have scoured that list and no ready boost in there. This I find VERY frustrating.

    Anyway else to enable it?
     
  2. Celestra

    Celestra Former Moderator

    Joined:
    Jan 15, 2008
    Messages:
    2,468
    Likes Received:
    14
  3. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    Do you have USB 2.0 plugs? That is the minimum requirement.
     
  4. alfrocks

    alfrocks New Member

    Joined:
    Dec 10, 2008
    Messages:
    4
    Likes Received:
    0
    Lol yes I do, but regardless when I open service.mcs or whatever should I not be able to see readyboost as on or off?
     
  5. Celestra

    Celestra Former Moderator

    Joined:
    Jan 15, 2008
    Messages:
    2,468
    Likes Received:
    14
    I think I know what's wrong. Try this:
     
  6. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    Yes. You should. I don't think the attachment from the previous poster will help with that.
    You may have an incompatibilty in your bios which prohibits Vista from seeing the readyboost capability, but , perhaps, if you attempt to activate the device, the service will enable.
    Try this:
    Insert the USB flash device, and let Vista detect the device. When it comes up and asks you want you want to do close the GUI and do not make any selection.
    Now go to USB Flash device in Windows Explorer or disk management and format the device. Format the USB device you plan to use for ReadyBoost with NTFS and cluster sizes of 4096.(The default) Name the drive something you can recognise.
    Now right click on the USB device and choose 'Properties' then the 'ReadyBoost' tab.
    On the ReadyBoost tab unckeck the box to stop testing the device every time.
    Now click the Test again button. If the tab changes from the test tab to a tab that gives you two options of 'Do not use this device' and 'Use this device'. Check the 'Use this device' box and do not make any other changes on the tab especially to the 'Space to reserve for system speed' slider, leave the 'Space to reserve for system speed' setting at what ever Vista recommended.
    Click 'Apply' then 'OK'.
    Next, go back to the tab and check the 'Do not use this device' item. Then in explorer re-format the device as FAT32. After re-format go back to the tab in step 5 and check the 'Use this device' item. Now your done, and if your device is compatible you can now use the device for ReadyBoost and should, hopefully, see the service..
     
  7. Celestra

    Celestra Former Moderator

    Joined:
    Jan 15, 2008
    Messages:
    2,468
    Likes Received:
    14
    Ah-- You think it is KB938371!! USB devices not being detected in Vista? My computer has not demonstrated anything wrong from the update. There is a workaround I read about.
     

Share This Page

Loading...