ReadyNAs - Access Denied

Discussion in 'Windows 7 Networking' started by Stugt40, Aug 6, 2010.

  1. Stugt40

    Stugt40 New Member

    Joined:
    Aug 6, 2010
    Messages:
    16
    Likes Received:
    0
    Hi

    I have a ReadyNas Duo which has been working fine on my old PC running XP. I have just installed a new PC with Win 7 and I am having all sorts of issues.

    I can see the NAS and access all of the folders and files. However, when I try and save them, I get 'Access Denied' messages. In Photoshop, for example, I get the message 'The file is Locked - Use the Properties command in Windows Explorer to unlock the file'. When I change the permissions ( they are listed as read only ) then 'apply' I get the message ' Unable to save permissions on 'file name' - access is denied'.

    In MS Publisher it tells me that the 'Drive is write protected' when I try to save.

    On the NAS itself, the CIFS default access is Read/Write and on the Advanced tab, Owner, Group and Everyone are set to Read/Write.

    I have tried the user access control at various settings and seems to make no difference ( I did restart after each change )

    This is driving me nuts !

    Any advice or help greatfully accepted!

    Thanks
     
  2. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    Control Panel -> Network and Sharing

    Does it say "Home Network"?
    If so you will have to change it over to a "Work Network" ...
    just click on "Home Network" and select from the list.

    Now click on "Advanced Sharing" and set the following...
    Network discovery should be ON
    File and Printer sharing should be ON
    Public Folder Sharing should be OFF
    Media Streaming should be OFF
    File Sharing Connections should be set to 40 bit encryption
    Password protected sharing should be OFF
    HomeGroup conncections shoud be on USERNAME and PASSWORD.

    On ALL of your win 7 machines.

    These settings take Win7 back to XP style sharing. So you will now have to set up file shares in the same way you used to do it in XP... right click a folder, select advanced sharing, set it to share, set permissions and so on.

    The reason for this is that very few devices actually understand Windows 7 "Home Networks" or IPv6 ... These things are currently just a windows 7 fantasy and with less than 15% market share the world is not carving a path to the new door.

    Hope this helps.
     
  3. Stugt40

    Stugt40 New Member

    Joined:
    Aug 6, 2010
    Messages:
    16
    Likes Received:
    0
    Hi

    Thanks for your response

    I tried your suggestion and I still get the same messages. When I right click on the folders, however, I do not get any option to set up shares but at the bottom of the drop down list I have 'proprties' and all the files have the 'Read Only' box highlighted. If I then try and edit the permissions, I get the same ' Access Denied' message. Any other ideas ?

    Thanks
     
  4. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    Perhaps you should check the share settings...

    You may have to add your own account to the permissions list (ACL) in order to get full access. Of course this will be done by the web setup utility of the NAS...

    Don't worry about the read only thing... If it's a blue square it just means there's at least one read only file in the folder. It does not mean you have no access.
     
  5. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    It may be an issue with Windows 7 using NTLMv2 and 128 bit encryption you may want to make sure that your ReadyNAS supports this, if not some people have had some success adjusting down the NTLMv2 and 128 bit encryption, it might be worth a try.. If you have Windows 7 Pro or above open the Security Policy Editor by typing secpol.msc into the search or run dialog box and make the edits as noted in the attachment and see if that helps. If you are using Home Premium then you will have to perform the adjustments using the registry editor. Make sure you create a restore point prior to any edits, and back up the key by exporting before you edit it. I've include some attachments that I hope will help.
     
  6. Stugt40

    Stugt40 New Member

    Joined:
    Aug 6, 2010
    Messages:
    16
    Likes Received:
    0
    Hi

    I had a thread going on the Netgear ReadyNas forum and someone came up with the cause - it's to do with the level of security on the share - it works fine on XP but has to be reset on the NAS management tool to work with WIn 7 64 which I just did and it's all fine now. Thanks very much for your efforts in trying to help me out - much appreciated.
     
  7. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    Glad you got it working...

    But, for future queries, how about posting the details on the fix?
     
  8. chhumper

    chhumper Well-Known Member

    Joined:
    Feb 2, 2011
    Messages:
    8
    Likes Received:
    0
    details please! this sounds like it might help fix my issue -- win 7 64. used to be able to access my shares. now cannot. specifics would be appreciated.
    thank you!
     
  9. Stugt40

    Stugt40 New Member

    Joined:
    Aug 6, 2010
    Messages:
    16
    Likes Received:
    0
    Hi.

    I tried several things and I am not sure which fixed it ( I am by no means any kind of expert ! ) but here is what I did:

    Open Control Panel, right click the NAS and select 'Properties'. Select the Security tab and make sure that the appropriate user ( I used 'Everyone' ) has all of the permissions selected that you need ( again, I selected everything for everyone )

    I then did the same on each folder on the NAS to make sure that the permissions cascaded down ( they did not when I checked ) so I enabled permissions on the folders as well. I seem to remember that I had to reboot the NAS before all this worked ( which confused the hell out of me at the time )

    Try this and see how you get on - let me know if it does not work and I will dig deeper into my flagging memory to see if I can come up with anything else.

    Good luck.
     
  10. Stugt40

    Stugt40 New Member

    Joined:
    Aug 6, 2010
    Messages:
    16
    Likes Received:
    0
    Just in case - here are my NAS Share settings ( that work )

    CIFS Selected

    Default Access - Read/Write

    Advanced CIFS - tick Automatic

    Group rights and everyone rights set to Read/Write

    oplocks enabled.


    Hope this helps
     
  11. chhumper

    chhumper Well-Known Member

    Joined:
    Feb 2, 2011
    Messages:
    8
    Likes Received:
    0
    thanks for the response.
    i can get into the share listings via the web interface -- readynas frontview. i went through and checked the settings on all of the shares and they're the same as you described.
    i cannot, however, complete the initial step. in windows explorer, when i right-click on the readynas, which is listed under 'computers,' i don't have a properties option. it is also listed under 'storage.' there, when i right-click, i can select properties, but it simply brings up a dialog box with basic information: device details and troubleshooting information. i don't have multiple tabs up top which i can click on.
    thoughts? suggestions?
    again, thanks for trying. curious to hear more about how you got your device working. when i try to access mine, i continue to be told it's not accessible and i might not have permission to use the network resource. blah.
     
  12. Stugt40

    Stugt40 New Member

    Joined:
    Aug 6, 2010
    Messages:
    16
    Likes Received:
    0
    Hi. I remember going through all this......Have a look at Home group sharing options.

    Go into Control Panel, Network and Internet, Homegroup and sharing options, Change Advanced Sharing Options:

    I have the following settings:

    Network Discovery - ON
    File & Printer Sharing - ON
    Public Folder Sharing - ON
    Media Streaming - ON
    File Sharing Connection - Use 128 bit encryption
    Password protected sharing - ON
    Homegroup connection - Allow Windows to Manage

    Hope this helps

    I will keep thinking about it - I may need to go through this again if I ever have to rebuild the hard disc ! Should have made notes.....
     
  13. Stugt40

    Stugt40 New Member

    Joined:
    Aug 6, 2010
    Messages:
    16
    Likes Received:
    0
    Just had another thought - but I'm sure you did this - did you map the network drive and connect it ?
     
  14. chhumper

    chhumper Well-Known Member

    Joined:
    Feb 2, 2011
    Messages:
    8
    Likes Received:
    0
    again, thanks so much for taking the time.
    so, i got it all working. here's what i stumbled upon and here's what did the trick:
    user accounts --> manage your credentials --> i then clicked on "add a windows credential"
    i manually added 192.168.1.100, entering my username and password for one of the readynas user accounts.
    then, in windows explorer, i went to \\192.168... and could see and access my shares.
    i tried, then, in explorer to navigate to \\readynas, which was always the way i got the my shares prior to reformatting. got the same permission error. i went back into the credentials portion of the user accounts page and manually added \\readynas, entering the same username and password. i could then navigate to \\readynas in windows explorer.
    so, problem mostly solved. given that the readynas is configured for open access, it still doesn't make a whole lot of sense. and i don't know what will happen when another computer on our network tries to access the shares, but we'll see.
    at this point, being able to see and access the files is what's most important, so that's that.
    again, thanks for keeping me persistent with this issue. hope this ends up helping someone in the future...
     
  15. Stugt40

    Stugt40 New Member

    Joined:
    Aug 6, 2010
    Messages:
    16
    Likes Received:
    0
    Well done ! At least you can get to your files now. Interestingly, I just checked my credentials are there are none at all ! Just goes to prove the old adage that there are many ways to skin a cat !
     
  16. Gopher Baroque

    Gopher Baroque New Member

    Joined:
    Feb 2, 2013
    Messages:
    2
    Likes Received:
    0
    I just survived a similar problem accessing a newly created share on ReadyNAS from Win 7. Previously created shares are open access but the new one required a login (but didn't like any logical credentials). The solution was to add a password to the new share (and apply, but you won't be able to log in since username is not known) and then remove it (and apply, then access is open).
     

Share This Page

Loading...