Really wierd sound problem in Windows 7 (x-fi + onboard)

Discussion in 'Windows 7 Hardware' started by stator, Sep 15, 2009.

  1. stator

    stator New Member

    Joined:
    Sep 15, 2009
    Messages:
    6
    Likes Received:
    0
    Hi everyone :D

    I've just installed Windows 7 on this PC but I'm having a very strange problem with the sound.

    I have an X-fi XtremeMusic PCI card which has worked fine in my old PC for years running on XP.

    Since installing Windows 7 the sounds are coming out very peculiar. Normal windows sounds which I guess are probably .wav files play perfectly, very clear and audible. When I try and play a .mp3 file however the main vocals of the track sound as if they were recorded with the singer about 100 yards away from the microphone. Certain instruments sound kinda normal but some of them are like the voices and very far away. I get exactly the same effect trying to play an audio CD. I have tried the inbuilt media player, creative media player and foobar mp3 player. All give the same effect.

    When I try and play HL2 most of it sounds fine but I can only hear the characters speech if I am facing away from them! If I face towards them it becomes very very quiet.

    I have installed the latest Windows 7 drivers from Creative (these are the first drivers I tried). Then I tried some old Creative Windows 7 Beta drivers and got exactly the same thing.

    All this time the onboard audio of my motherboard was disabled. So I then tried enabling the onboard audio and installed the latest drivers from the ASUS website. I got exactly the same problem :eek:

    I really don't understand what is going on at all. Especially because normal windows sounds come out fine but just certain sounds within all my mp3's along with the HL2 issue. I'm using headphones but they work fine with other devices.

    Anyone got any ideas?
     
  2. Highwayman

    Highwayman Extraordinary Member

    Joined:
    Jun 3, 2009
    Messages:
    3,977
    Likes Received:
    112
    first port of call is the on the sound mixer for playback devices....theres a feature called "Enable audio enhancements" on the properties of the speakers tab usually...that forces on 3d sound, try turning that off. Also check you have not got the SRS WOW enabled on media player
     
  3. stator

    stator New Member

    Joined:
    Sep 15, 2009
    Messages:
    6
    Likes Received:
    0
    Thanks for the suggestions, I have checked what you said and there is an option "Disable Sound Blaster enchacements" which I have now ticked but I still get exactly the same problem. Also SRS WOW is already turned off in media player :(
     
  4. Highwayman

    Highwayman Extraordinary Member

    Joined:
    Jun 3, 2009
    Messages:
    3,977
    Likes Received:
    112
    Are you running 5.1 or 7.1 mode speakers? maybe try set to 2 stereo setting incase its that.
     
  5. stator

    stator New Member

    Joined:
    Sep 15, 2009
    Messages:
    6
    Likes Received:
    0
    No I was running headphones, but it seems they are broken now and using a pair of travel headphones the sound is okay (although I have to put my head within 30cm of the PC). I don't really understand when they must have broken as they have been working fine for months. Probably all of this plugging in and out that's done it :confused:
     
  6. Highwayman

    Highwayman Extraordinary Member

    Joined:
    Jun 3, 2009
    Messages:
    3,977
    Likes Received:
    112
    lol well even on headphones you can select number of speakers...at least you found it wasn't the PC
     

Share This Page

Loading...