realtek hd audio problem

#1
Hello guys. I'm having a nasty issue with realtek hd audio and win 7 x64. Until today, i had 7 x86 and the sound worked just fine. 5.1 and stuff, with no problems. After a clean install of x64, i only get 4 out of 6 speakers to play on the test. Front Left and Center don't work. With the 32bits version it worked like a charm. I'm using the latest drivers from realtek, but nothing :(
my mobo is a gigabyte M55S-S3 with realtek hd audio onboard. like i said, i have the latest drivers, including a bios update.
Still doesn't work :(. any ideas? Thank you
 


#2
Realtek Tray Icon (or Control Panel > Realtek) > Open Realtek Sound Manager > Speakers Tab > Speakers Coonfiguration > select your scheme.
 


#3
already done that. I'm not that newbie. I've selected the 5.1 scheme, the cables are inserted properly(besides, realtek has that pop-up menu when you plug/unplug the jacks, so you can't plug in the wrong holes). Like i said before, i only got this problem with se7ven x64. On xp, vista x86, x64, 7 x86 NO ISSUE at all :(.
I've tried many things, like uninstalling the latest driver (2.40) and installed ALL the drivers from beta versions. Nothing. I'm having a dual boot system, with xp. On xp works, so it's not hardware-related.
My 5.1 system si a Labtec Arena.
 


#4
My sound is Realtek HD Audio and I use 5.1 speakers with Creative Labs speakers on my 7x64. In your case, it can be either a driver issue or your speakers incompatible with Realtek. I assume you have the latest Realtek driver. Did you contact Realtek and Labtec Arena ?
 


reghakr

Essential Member
#5
Could you give us the exact make and model of the Realtek card

Go to Device manage and click on the Sound, Video,and game Controllers entry

Then go here:
http://www.realtek.com.tw/DOWNLOADS/
 


#7
OK, full system specs.
Gigabyte M55S-S3(rev 2.0) with Realtek ALC883 Audio Codec
AMD Athlon X2 4400+
4Gb RAM(the reason i;ve moved on to x64)
Ati Radeon 4670 (i didn't install the hdmi audio drivers, as i had some problems in the past).
and the rest i don't think it matters that much.
Thanks for the fast replies.
 


#8
Control Panel => Sound => Playback tab => Right-click on Speakers and choose Properties => See if all your speakers show up

Control Panel => Sound => Playback tab => Configuration button
 


reghakr

Essential Member
#9
Did you go to Device manage and click on the Sound, Video,and game Controllers entry and get any useful information?
 


#10
checked. All entries on 100. Latest driver already installed manually. The scheme is ok, as you can see.
My speakers are paired like this on green cable FL+FR, on black RR+RL, on pink Center+Sub.
When i run the tests, the center and FL don't work.
1.jpg
 


#11
Did you go to Device manage and click on the Sound, Video,and game Controllers entry and get any useful information?
Like i said, i have Realtek HD ALC883(onboard audio) on my gigabyte m55S-S3. Damn. I think i will roll back to 7x86. I just can't figure it out.
The system works fine, so i eliminated any hardware fault. Maybe it's driver incompatibility with my motherboard. But with 7x86 works like a dream. That's why i'm so confused
 


#12
Ok, unplug the Center speaker and swap it with the left or right one, to be sure that the speaker is actually working. If alright, then I suspect your Realtek driver, what's the driver version ?
 


#13
Also do this to see if there are any yellow spots there:


Did you go to Device manage and click on the Sound, Video,and game Controllers entry and get any useful information?

Click on any "yellow" device under Sound/Video/Game controllers > Driver > Update (> browse to dowanloaded and extracted Realtek driver).
 


#14
latest driver from realtek R2.40(6.0.1.6013). Downloaded it today, as i installed the OS :). Same driver on x86 worked and it works on xp x86 with sp3.
i will try something else now. I wil download the zip file and try to figure out something from the files there.
 


#15
R2.40(6.0.1.6013) works fine with my Realtek on my 7x64, so maybe try uninstalling it completely and then installing it again.
 


reghakr

Essential Member
#16
Unzip the file and look for an .inf file.

Now goto Device Manager, click Sound, Video, and Game Controllers and select update driver software choosing the .inf file in the extracted directory
 


#17
pff. 6kb/s from the realtek site :). I have another idea, though. I just downloaded the audio driver from the gigabyte site. Maybe it will work with manufacturer;s driver. if not, and the zipped driver won't help either, ,.....just roll back to 7x86 and sell 1 gb ram :)
L.E.
I have managed to solve the problem. Extracted that zip file, and just updated the driver. After that i rearranged the jacks. totally mixed up them, but it works :)). thank you for your help. Keep up the good job :D
 


Last edited:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.