Realtek HD SPDIF Audio

Discussion in 'Windows 7 Hardware' started by silentHTPC, Nov 9, 2010.

  1. silentHTPC

    silentHTPC New Member

    Joined:
    Nov 9, 2010
    Messages:
    4
    Likes Received:
    0
    Hello.

    I am struggling to get a stable Dolby output on SPDIF.

    I have a Gigabyte GA-880GMA-UD2H (rev 2.1) and latest BIOS (F5), AM3 445 and 4 GB of ram running on a fresh install of W7 64 bit. The onboard audio is a Realtek ALC892 I have downloaded the latest driver from the Gigabyte website. I have managed to get the sound working on the SPDIF for a while but if I reboot it turns into a mumbled static mess, then on another reboot will completely dissappear. The HDMI HD audio and the analog outputs work fine, it's only the SPDIF that fails.

    I can see the SPDIF setup in the Realtek HD Audio manager and when I run the test sounds I see the levels bounce up just fine on the mixer.

    I've tried downloading direct from realtek website their latest driver also with no success. I've also uninstalled the realtek drivers and allowed windows to run it's own which again just worked for the first boot before falling over.

    In order to get the sound back I have to uninstall everything and re-run all the driver installs and re-boot. Sometimes the sound comes back, sometimes I have to reinstall multiple times. It seems very strange that I can get it working but then all goes bad after a reboot, maybe windows is tryign to take control on the reboot and putting the wrong driver in????

    There a lot of versions of the real-tek driver so maybe one particular one works best with 64 bit. Either way this is getting very frustrating for a brand new kit for something so simple.

    Any ideas please post.
     
  2. bassfisher6522

    bassfisher6522 Essential Member

    Joined:
    Aug 27, 2008
    Messages:
    4,884
    Likes Received:
    318
    Try downloading latest driver and save file to desktop. Then uninstall current driver and reboot,if windows starts to install it's version, if it has one cancel it. Then install latest driver that you saved to desktop.
     
  3. bassfisher6522

    bassfisher6522 Essential Member

    Joined:
    Aug 27, 2008
    Messages:
    4,884
    Likes Received:
    318
    Sorry, I see you have done that already. Try it again anyway. Next, try updating your bios, it maybe do to some mobo compatibility thing with onboard sound chip. To verify this issue, if you have or a friend has an add on sound card, install the sound card and see if problem is still there.
     
  4. silentHTPC

    silentHTPC New Member

    Joined:
    Nov 9, 2010
    Messages:
    4
    Likes Received:
    0
    I've updated the BIOS to latest and rebuilt the entire system. Exactly the same thing happened. It worked perfectly until the first reboot then no sound. I have the driver supplied with the motherboard so I will install the latest update from Gigabyte tonight and see if that helps.
     
  5. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372

Share This Page

Loading...