Remap right Alt to AltGr?

Discussion in 'Windows 7 Tutorials' started by MikEst, Feb 12, 2011.

  1. MikEst

    MikEst New Member

    Joined:
    Feb 12, 2011
    Messages:
    8
    Likes Received:
    0
    I just bought a Dell XPS 15 and discovered that there's no AltGr, but two Alt's instead. Is it possible to remap the right Alt to act as AltGr?

    I've tried several keyboard editing programs, but haven't found any with that option (except KbdEdit, but the demo version won't let you save the settings and 8€/12$ is quite a lot to pay only to change one key).
     
  2. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    [langtitle=hr]Re: Remap right Alt to AltGr?[/langtitle]

    Autohotkey will let you remap:


    Left Alt to AltGr:

    Code:
    [B]LAlt::Send {AltGr}[/B]


    Right Alt to AltGr:

    Code:
    [B]RAlt::Send {AltGr}[/B]
     
    #2 cybercore, Feb 12, 2011
    Last edited: Feb 12, 2011
  3. MikEst

    MikEst New Member

    Joined:
    Feb 12, 2011
    Messages:
    8
    Likes Received:
    0
    Thank you for your answer, but that doesn't work either - right Alt still doesn't function as AltGr.
     
  4. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    1. Did you install Autohotkey?

    2.
    Code:
    [B]RAlt::Send {AltGr}[/B]
    Did you save this code as name.ahk?


    3. Did you double click on the script to launch it?


    If you answered No to any of these questions, you know why it doesn't work.
     
  5. MikEst

    MikEst New Member

    Joined:
    Feb 12, 2011
    Messages:
    8
    Likes Received:
    0
    Yes, of course I did all those things.
     
    #5 MikEst, Feb 12, 2011
    Last edited: Feb 12, 2011
  6. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,817
    Likes Received:
    1,563
    Hi MikEst,

    a couple of things to suggest and apologies if you've tried these already.. Have you tried setting the keyboard to UK input? Another option would be to try the keys of 'Control & Alt' as these should produce AltGr when used together.

    More information on this subject can be found here:

    AltGr key - Wikipedia, the free encyclopedia
     
    1 person likes this.
  7. MikEst

    MikEst New Member

    Joined:
    Feb 12, 2011
    Messages:
    8
    Likes Received:
    0
    Thank you fro your answer, but switching to UK input didn't help either. And I already know that Ctrl+Alt=AltGr (btw, that didn't work in the UK input).

    But I got it to work. The program that I mentioned in the original post (KbdEdit) creates a temporary layout called "Language [KbdEdit Preview]". While KbdEdit was still open, I opened the layout with MS Keyboard Layout Creator 1.4 and then closed KbdEdit. The layout then saved and I was able to select it from the input language / keyboard settings.
     
  8. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,817
    Likes Received:
    1,563
    Glad to hear you got it sorted and much thanks for updating the thread.
     

Share This Page

Loading...