Remote Desktop Connection TimeOut

rspiet

New Member
Is there a way to change the Remote Desktop Connection Time Out period. I use Windows 10 RDC App to log into Windows 2012 and 2016 Servers. If these are open, and I go back to my Windows 10 computer, they timeout within a few minutes and I have to reenter my password to go back to the RDC connection. Is there a way to increase this timeout period. It seems way too short.
 

wahaha

New Member
To prevent Remote Desktop Conenction from being timeout, I think there are 2 ways to keep RDP session alive. The first one is adjust the time limit in Group Policy Editor. The other one is add a registr key KeepAliveEnable. For the concrete steps, you can read this post Top 2 Ways to Keep RDP Session Alive I hope it can help you
 

AdrianG001

Senior Member
The settings of RDP session timeouts are located in the following GPO section Computer Configuration -> Policies -> Administrative Templates -> Windows Components -> Azure Remote Desktop Services -> Remote Desktop Session Host -> Session Time Limits.
 
Top