Remote Desktop Problem

#1
I'm using Windows 7 RC and having problems with the Remote Desktop feature.
I can connect to a remote computer fine but when I logoff, the connection then seems to disconnect but then
Window locksup! I cannot just close the window but have to go into Task Manager to end each window task! This is really an annoying problem since I do use Remote Desktop connection alot. Anyone have any solutions
 


Last edited:
#2
Has anyone else experienced this problem with Remote Desktop?
 


#3
Not yet...I will test it for you tho..

Is this happening when you RDP into the Win7 machine, or to an XP/Vista PC from the Win7 PC?...are you using build 7100? - I found that I had much better luck using 7127, but haven't tested your specific issue.

On the RDP PC, are you logging off? or simply closing the remote session? I have some luck once in a while in XP by clicking logoff, then quickly minimizing the window and doing a right-click, close...but I usually do that to kill the pop up window.

I'll let you know if I can duplicate the problem....
 


#4
I have both Windows XP & Windows 7 build 7100 computers that I RDP into and they both do the same thing. I can logoff the session but when I try to close the window it just locks up. I have to use the Task Manager to close the window by ending the window IE task. The RDP session works fine until I try to logoff. Very annoying!!
 


#5
Thanks Halcion1 for your feedback! I downloaded and installed build 7229. No longer have this problem! Must be a flaw in build 7100.
 


#6
Wonder if i could hijack this thread a bit instead of starting yet another about remote desktop?.

Anyways i have a question reagarding Remote desktop.

When connecting to the remote desktop (i'm using the "maximum number of sessions=1" trick to connect to the same session already running on my HTPC.)
....so anyways, connecting and all works well, its the logoff procedure i'd like to modify, when exiting the Remote session on my HTPC it ends up at the Logon screen in Win 7 (wich i guess is the normal state), is it possible to skip that and make the HTPC automatically "login" (log back on) to the active session again when exiting the remote session?

INFO:
Running 2 machines with Win 7 x64 both 7100
I also have the "Automatic login with password" trick on my HTPC enabled, doesn't seem to help with my above question though, but this is for the convinience of rebooting the HTPC and do a automatic login (several people us this machine, and having a "enter password" at login kind of complicates things when you dont have any keyboard attached :D ...thus my question.)
 


Last edited:
#7
Guys , i REALLY need your help now, and your gonna laugh at me, i know i'm a noob and i deserve it ;)

Heres the deal, my last question i finally got a solution too, heres what i did.

Made a .bat file on the desktop of the host computer with these lines in it:
"tscon.exe 1 /dest:console"
Then when i was done "remoting" i just double clicked that file and i was "kicked" from the host and the host returned to the "original" session,no logon screen and all, worked like a charm!!!

Now to my problem.
Yesterday i scrapped my 7100 beta for a real copy of Win 7 x64 professional= format etcetc you know the drill.
BUT forgot to backup my bookmarks!!!! so now, i cant find the page wich explained how to, as i called it in my previously post "Maximum number of sessions=1 trick" damn! i've searched the bloody whole internet, and find tons of Remote desktop pages, but none that explains how to change maximum sessions to 1 (wich i guess did the trick for me, cause if i just click my bat file now, it just blinks, and nothing more happens).

I kinda remember i was in "group policy" editor or something like that, cheked it out and yeah, its close enough, BUT cant seem to find anywhere in there the lines "Maximum number of sessions=1" so PLEASE someone point me in the right directions.

PS:
Iv'e tried 2 other disconnect tricks wich was supposed to work in a similar fashion...none of them worked.

Bat file 1 with these lines
@%windir%\System32\tscon.exe 0 /dest:console
@%windir%\System32\tscon.exe 1 /dest:console
@%windir%\System32\tscon.exe 2 /dest:console

Bat file 2 with these lines
@echo off
tscon 1 /DEST:console /PASSWORD:xxxxx
start %windir%\ehome\ehshell.exe /directmedia:general

Like i said none worked for me

My specs:
Computer 1
Lenovo T61
RDP Client, Win 7 X64 Ultimate beta RC 7100

Computer 2
HTPC
RDP Host, Win 7 X64 Professional

Hope someone can help me, Cheers
/Doggen
 


#8
Ok, im talking to myself here ;) .....just fyi i found the answer.

So, i started "Local group policy editor"
and went to:
Computer configuration
Admin templates
windows components
remote desktop services
remote desktop session host
connections
And there edited the line "Limit number of connections" , entered the number "1", apply, rebooted
and tried my disconnect.bat file ( with "tscon.exe 1 /dest:console" in it)

SO, i thought this would work like before now, but noooooo, it didn't ??? why not i wonder?
Any difference between Win 7 x64 RC 7100 and the Win 7 x64 Proffesional?
OR am i doing something else wrong?
 


#9
SUCCES!

Found the solution....it was easier than i thought ;)
I ran the bat file as "Administrator" and then "poff!" dissconnected and the host returned to desktop without ending up at the logon screen so IM HAPPY!

So in conclusion, if you have problems as i had, read my 4 last post and sumarize, and you too can be a happy camper :p

/Doggen
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.