Restore from ext hdd not responding

My old pc was running vista and crapped out on me. I now have a new PC running win7. My old PC was backed up on a MYBOOKWORLD external harddrive that is shared on my network. When I goto restore the files, after hitting the "next" button (pictured) the sys will not respond. Please can anyone tell me how I can get my backed up docs,videos, pics, ect on my new machine? thanks

Joe S

Excellent Member
Is your Windows 7 network setup properly? Home Group only works on Windows 7 computers. What did you backup with?

Is your Windows 7 network setup properly? Home Group only works on Windows 7 computers. What did you backup with?

My network is setup as home. I backed you with windows auto backup to an external hard drive on the network. i can locate it and select it when trying to restore, but it does not respond. this computer is brand new.


Senior Member
Have you tried to connect the Ext HD directly to the PC rather than going through the network? This might solve your immediate problem of getting your data back.


Excellent Member
Microsoft Community Contributor
I am with Ted on this. Windows 7 might be adding security you are not yet used to. But can you access the folder with the files otherwise and you feel that there is not some restriction when the Backup tries to do so?

If you have another location available, could you copy the backup there--might take a while...

Any messages in the Event Viewer after the failed attempt?

As far as I can tell, restoring a Vista backup should not be a problem, but this video goes through the process. It mentions things like restoring to a different user name.


Essential Member
Microsoft Community Contributor

I would suggest that try copying the backup directly to a folder on your hard drive, if it copies OK that shows that it's readable at least.

Then I would try and run the backup as Administrator bypassing most of the Windows security blocks.

If is still doesn't read is it possible for you to still access your old hard drive.
You could buy a cheap USB adapter and plug it right into your new computer.


How to Enable the Administrator Account

Open the command prompt with elevated privileges by clicking the Start orb, All Programs, Accessories, right-click Command Prompt and then select Run as administrator.

Type or cut and paste…

net user administrator /active:yes

and then press Enter.

Log out and log back in as Administrator.

When you are done undue the process by doing the same thing and pasting in

net user administrator /active:no

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.