Restored DriveImage XML, Win 7 won't boot

Discussion in 'Windows 7 Software' started by raiden1701, Feb 28, 2011.

  1. raiden1701

    raiden1701 New Member

    Joined:
    Feb 28, 2011
    Messages:
    42
    Likes Received:
    0
    My Windows 7 Ultimate 32bit OS got messed up so I restored the original image I made from DriveImage XML successfully. Now when my PC boots, I get the mobo splash screen and then just a cursor. When I put my Win 7 install disk in I can "press any key" to boot from it and the DVD goes right to where I can repair my installation. It sees my partition and when I use the cmd prompt using diskpart, I can see that the win 7 volume is c:\, active, and all my files are in the right spot. However when I look at the volume numbers, my c:\ is volume 2 and my DVD drives are volumes 1 & 2. So how do I change my c:\ drive to volume 0? I've read that this is how you set the c:\ to boot properly. If I'm wrong please correct me.

    The Win 7 drive is a WD 500gb IDE. When I put this drive into any other PC, it does the same thing. Mobo splash or POST screen then just a cursor. I can't enter Safe Mode or anything except to put a disc in the DVD drive and boot from it. I tried fiddling with my mobo settings and they are normal. If I take my Win 7 drive out and put it as a slave or as a USB external drive, I can see everything and do whatever with the files.
     
  2. raiden1701

    raiden1701 New Member

    Joined:
    Feb 28, 2011
    Messages:
    42
    Likes Received:
    0
    I fixed it. This is what I did:

    Click on Command Prompt.

    A) Type c: and press <Enter>.

    Note Note
    C:\ is the drive letter where Windows 7 is installed. You may replace it with whatever drive letter you want where you have installed Windows 7.


    B) At the C:\ prompt, type cd boot and press <Enter>.

    C) At the C:\Boot prompt, type the following commands and press Enter after each command.

    Code:

    bootrec /RebuildBcd
    bootrec /FixMbr
    bootrec /FixBoot
     

Share This Page

Loading...