Right Click menu not showing in Windows Explorer

Discussion in 'Windows 7 Help and Support' started by gguevara, Mar 17, 2011.

  1. gguevara

    gguevara New Member

    Joined:
    Mar 16, 2011
    Messages:
    4
    Likes Received:
    0
    Hello,

    I have read several threads in different forums regarding different types of issues with right clicking in Win 7 x64. My issue is when right clicking on folders/files within the Window Explorer. Below is my set up:

    Win 7 Ultimate (64) - SP1 Build 7601
    AMD Athlon 64 X2 4800 (2.47Ghz dual core)
    Asus AV8 Deluxe
    4GB ram
    Nvidia GeForce FX 5200 (Driver 96.85)

    I am logged in as Administrator by default. I did not have this issue before.
    I only have the following installed (in order of installation):
    Office 2007 / IE / Firefox / MS Security Essentials / Spyware Doctor / Malwarebytes / Adobe Master Collection CS4 / AVS4You Suite / WinRAR / VLC player / Picasa / Orbit Down Loader / Mp3tag / and Rocketdock with Stack docklet

    Issue:
    I can right click on the desktop, desktop icons, task bar, and start menu with no problems (including inside the start menu). As an example - if a go to the start menu and left click on My Computer, the Windows Explorer will open as normal (displaying all my drives). At this level I can right click on my drives and the menu pops up with no problems. But as a further example - if I left click on my C: drive, in order to go into the next level in Windows Explorer, I will see the folder/files inside the C: drive (like normal). But at this point (or further levels), if I right click on any folders or files - the menu will pop up so fast (like a split second flash) and go away. It does not give me the chance to do anything. And after this split second flash, the Windows Explorer goes back to the previous level (as if I hit the Back button).

    It does not matter how deep I navigate into the folder structure (anything past the first level - where the Drives are displayed) - as soon as I right click, the same "flash" happens. Including the backing up of a level each time I right click, until I end up back at my Drives again. Yet if I were to copy-n-move any folder/file to the desk top level, then I can right click like normal (even though within the Windows Explorer I could not).

    Is this a Security/Permission setting? Or is this a corrupted Context Menu issue (inside one of the registry levels)?

    Any help would be greatly appreciated. In the mean time I will try using the ShellExView utility to see if I can isolate the issue. I just dont know if I should only concentrate on Non-Windows context menus, or look at all the context menus.

    Thanks again for any help on this (and appologies for being a bit wordy),
    gg
     
  2. gguevara

    gguevara New Member

    Joined:
    Mar 16, 2011
    Messages:
    4
    Likes Received:
    0
    Solved:

    Apparently it was my mouse (Kensington - Expert Trackball). I had it connected to the PS2 mouse input, and it was never a problem before. Even though I had the latest Vista/Win7 driver - this driver version is not designed to work with PS2 (for Win7). It is supposed to be used for USB mouse only. So I removed my PS2 adapter from the end of the cable and plugged the trackball directly to the USB and it worked (after Win7 re-directed itself to the Kensington driver).

    Now everything works as normal. It was working fine once before, but I guess it destabilized and started to act up. But now all is peaches-n-cream again.

    Hope this helps someone in the future.

    Thanks,
    gg
     
  3. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    gguevara;
    Hello and welcome to the forum. Thanks so much for the follow-up and updating your thread with the solution that worked for you. This is exactly the kind of information regarding specific hardware issues that other members as well as visitors will find very helpful. Hope to continue to see you around the forums.
    Thanks for joining our community.
    Randy
     

Share This Page

Loading...