"Run as Administrator" in Properties not recognized;Why still UAC prompt?

pstein

Honorable Member
#1
I enabled the checkbox in the properties->Compatibility tab of a certain *.exe

Privilege level:
Run this program as an administrator=yes

The check in the checkbox is accepted.
I click "apply" and close the properties.

However when double click afterwards on such an *.exe in WinExplorer the UAC prompt re-appears again.

How can I permanently get rid of this UAC prompt dialog for certain (not all) programs?

Peter
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#2
Hi

I think this may help with your problem.

Windows 7 has it's own ideas about what logged in as administrator means.
If you really want to do something as an Admin. you have to go through this process.


How to Enable the Administrator Account

1. Open the command prompt with elevated privileges.

Do this by clicking the Start orb, All Programs, Accessories, right-click Command Prompt and then select Run as administrator.

2. Type: net user administrator /active:yes and then press Enter.

You will now have two login options your usual one and Administrator.

To get back to not having this option, do the whole thing again and type in...

net user administrator /active:no

Mike
 


Last edited:

pstein

Honorable Member
#3
Ok, thank you.

But this is an uncomfortable solution.
I cannot imagine that there is no official shorter+smarter way.
Peter
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#4
Hi

Sorry, I didn't really understand your question.

I don't know how to do that for individual programs.

You can do it for all programs with the security level slider, but as you said clicking the run as administrator check box seems to have no effect on the UAC.

Mike
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.