Running an old program in Windows 7

Discussion in 'Windows 7 Software' started by GeekOnAmission, Aug 24, 2009.

  1. GeekOnAmission

    GeekOnAmission New Member

    Joined:
    Aug 24, 2009
    Messages:
    6
    Likes Received:
    0
    Hello, my company uses an old accounting program that was designed for Windows 98. I have had this run on everything up to Windows XP SP3. Now that I have upgraded my computer, I can't get is to run in Windows 7. I have tried all of the usual compatability things, but I am not making any progress. It instantly throws up a message saying that says:

    "The version of this file is not compatible with the version of Windows you're running. Check your computer's system information to see whether you need an x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher."

    This message comes up the second I try to start the installer. It is a very basic program, and I am sure it would run fine if it could ignore the fact it is in a very advanced computer. I appreciate the help with this, I really need to get it going, and I really don't want to limit my brand new hardware with Windows XP.
     
  2. GeekOnAmission

    GeekOnAmission New Member

    Joined:
    Aug 24, 2009
    Messages:
    6
    Likes Received:
    0
    OK, I looked into it, and it appears that this is a 16 bit app, anyone know how to get around this? I am trying the virtual xp download now.
     
  3. Joe S

    Joe S Excellent Member

    Joined:
    Jan 12, 2009
    Messages:
    3,785
    Likes Received:
    113
    I had a bike log program with about 10 years of info that wouldn't install on 64 bit Vista or Windows 7 that I got when I had 98. I used Windows easy transfer utility and it worked. I think the problem is a 16 bit installer.
    Doing some more experimenting on virtual PC I found if copied the whole program file with sub file to C drive or whatever then I just double clicked the registry file it installed ok after copying shortcut. It might work since it may not need drivers. Let us know if it works there isn't much information on this.
    Joe
     
  4. GeekOnAmission

    GeekOnAmission New Member

    Joined:
    Aug 24, 2009
    Messages:
    6
    Likes Received:
    0
    Thanks Joe, but I just got her all figured out :) All I had to do was download the new version of virtual PC from Microsoft, then the virtual XP package for Windows 7, and install the program in the VPC of XP, then it will appear in your windows 7 start menu, as a ready to go program. The only problem is with this method, it won't automatically forward some devices, so if you have a security dongle for example, it will only work when you are actually operating in the shell of the VPC, and have clicked to attach the USP Hasp lock. Other than that though, it is working very well. Thanks for the help.
     

Share This Page

Loading...