S4 Doze to Hibernation

#1
My computer wakes every night at around 4am. In the event viewer, the reason is "S4 Doze to Hibernation". I cannot figure out how to force the computer to stay in sleep mode. I do, however, want the computer to allow hibernation on battery, so disabling hibernational all together won't work.
 


#2
Here is some info I read:

open Command Prompt as administrator, then type the following command line:

powercfg /lastwake (press Enter)
If that doesn't work try it like this powercfg -lastwake

Check if some more information is shown rather than unknown source.

Still in the Command Prompt window, type the following command-line:

powercfg /devicequery wake_armed (press Enter)
or... powercfg -devicequery wake_armed

The command will help you check which devices may wake the computer wake up.


In device manager, right-click the device listed in Step 3 and select Properties, switch to Power Management tab and clear the checkbox of Allow this device to wake the computer.

Microsoft's tech page for powercfg commands:

http://technet.microsoft.com/en-us/library/cc748940(WS.10).aspx
 


Last edited:

Saltgrass

Excellent Member
Microsoft Community Contributor
#3
Windows Help and Support has some things you can check. Search for "wake from hibernation" then look for the question why does it wake unexpectedly
 


#4
My point in the first post, and a point I obviously didn't make clear enough, it that there is obviously a setting somewhere that allows the computer to change from sleep mode to hibernation by waking. This isn't a device waking the computer, nor an Unknown source. The source is: "S4 Doze to Hibernation".

My question, I guess would be, WHERE is this setting?
 


#5
My point in the first post, and a point I obviously didn't make clear enough, it that there is obviously a setting somewhere that allows the computer to change from sleep mode to hibernation by waking. This isn't a device waking the computer, nor an Unknown source. The source is: "S4 Doze to Hibernation".

My question, I guess would be, WHERE is this setting?
Click Start and type Power and go to power options

I think Scheduled Task will wake up a computer? Anyone know? It may be coming on to update windows. What time is that set for?

I would disable Hibernation if it were mine. I have read that hibernation actually takes more battery power.. even though you should be plugged in if it's coming on during your sleep... and power isn't a consern. Hibernation has to do a LOT of hard drive activity to build the file it will restore.... then spin the drive again to read it.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#6
Do the sleep/hybrid sleep/Hibernate after settings you show in Advanced Power settings correspond to the time the system is waking up? Change you settings so you can watch it to see what it is doing.

Do you think it is waking up because it is attempting to hibernate?
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#7
I just noticed that Windows Update has a default setting to do updates at 3 am, for me. It states it might wake the computer.

What did the powercfg -lastwake show?
 


#8
I just noticed that Windows Update has a default setting to do updates at 3 am, for me. It states it might wake the computer.

What did the powercfg -lastwake show?
It shows NOTHING because it's not a valid command... I made a MISTAKE the "-" should be "/"

I should have tested it, I thought it came from Microsoft's tech notes site. I have edited the message and corrected it.

I'm so embarrassed.
 


#9
I just noticed that Windows Update has a default setting to do updates at 3 am, for me. It states it might wake the computer.

What did the powercfg -lastwake show?
Well crap... now "-" works.... but it didn't work before. Microsofts tech page shows the commands using -

Powercfg Command-Line Options

Now I don't know what to do?
 


#10
I also had the same problem. I never shut down my laptop, I always put it into sleep mode, and it would wake up unexpectedly in the middle of the night. I discovered that this "S4 Doze to Hibernate" event is not a bug, it's a feature. Go to power advanced settings and change "hibernate after" under "sleep" drop down menu:

S4_doze_to_hibernate.png



Choose how long you want to wait before going to hibernate from sleep mode. I set mine to 1440 minutes (24 hours) which is enough for staying overnight.

By the way, also check you don't have anything under "allow wake timers".

P.D: I found this via Balanced Power Plan – czyli jak straszyć w nocy

 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.