save file on external drive not the same as internal drive

pintree3

Senior Member
#1
Why do files moved to an external drive not behave the same as those same files in an internal drive? I noticed that if I do anything to a file that is in an external drive, that file can not be saved under the same name (read only). In order to do so one must save it internally and then copy or move it to the external drive.
So I did just that--I copied a file from taken from an external drive, saved it in the internal one and then copied it back to the external one. Now if I r-click the propeerties of these 2 same files and then go to the 'Security' tab a difference is immediately apparent: The internal one has -1- System & -2 My-computername (user-PC\user and -3- Administrators (user-PC\Administrators) with all 3 accounts allowing all (full control, read, write, etc..). While the external drive has in Properties; -1- System -2- Administrators (user-PC\Administrators) and -3- Users (user-PC\Userrs) with this final 3d one (and different one) with no Allow for "full control, or modify or write.
So how does one have all its files in this external drive behave and be equal to all the same files in the internal drive?
Since -3- Users (user-PC\Userrs) in the external drive is that which is differnt from the internal drive I was wondering if it is OK to delete this Permission or 'attribute' or whatever it is called and create instead one equal to the one in the internal drive -3- Administrators (user-PC\Administrators)? ANd of course doing so in one go and not file after file after file, individually, would be ideal.

Any suggestions my friends?

Thank you
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
First Question--what type of file is it?

What type of external drive is it? A retail or an enclosed hard drive you put together?

What type of connection, USB, eSATA, Firewire, or what?

What---oh, I have run out of questions !! :)

My first thought is that some software is controlling what you can do, which might be associated with the external drive, or it is some type of protected file.

I should also mention, many files inherit the permissions of the folder in which they are placed. May not be true in your situation, but something to keep in mind.
 


Last edited:

pintree3

Senior Member
#3
saltgrass, I have to admit u have one of the most interesting/original names I have seen in quite a while--would be curious to know how it came to be. But besides this I must thank you for taking the time in trying to help me. What kind of external drive? It's one of those really small ones you carry around with your labtop. 500Gb Seagate. Connection USB. As to the type of file? All of them Office, music, you name it--always the same results: can't be worked on and saved in the same drive and the same file always has different properties external drv. vs. internal drv. My research shows that the problem is truly one of windows and not the drive itself, but yes I may be wrong and hence my hoping that nice people like you may know more and help.
 


whs

Extraordinary Member
#4
This story is a bit strange. Try this: Make a seperate library for the Seagate and INCLUDE the folders on the Seagate into that library (just right click on the folders and you will see). Then see whether the problems go away when you work thru the library.
 


pintree3

Senior Member
#5
Hi Once again thanks
I read u I asked myself; What is a library? Do I create a new folder and then move everything from the ext drive into that new folder? Anyhow assuming a library meant a new folder and to create this new folder in the external drive, I did as you asked--and it worked. And then things got weird. Seeing that just creating a new folder and moving the files to that folder worked I proceeded to do the same for every other folder, subfolder and files. But before going too far into this I decided to test another file. And it no longer worked. I asked myself what is different between this Word file and the other one? And then I remembered the other file I had manually changed permissions within the properties--Security tab. I proceeded to do the same--give it permission and it worked. What this means is that in order to do what I originally asked I must do 3 things, -1-create a new folder -2-move the files into that new folder and -3- manually give each file permission. This begs a new question: Is there a way to do this 'manual permission' process in a batch? I ask this because giving permission manually to each and every file will take months.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#6
I made a little graphic that might help. You can make these with the snipping tool and use Paint to edit, then attach using the paperclip on advanced replies.

But it shows the permissions on the external drive. You can see normal users only have the Read abiltiy. But if it is your file, you are not a normal user. These can be changed, although I have not tried, to suit your needs. But Authenticated Users and Admins can read and write.

The first two properties boxes are for a notepad file I made and copied to the external drive (you can tell from the path). I had no problems opening it from there and editing and saving back to the external.

Maybe for now, open Computer and right click and get the properties for it to see how the security is set up.

Edit: You can also change the Sharing options to give users read and write permission....for the entire drive, or just a folder on the drive where you keep specific files.
 


Attachments

Last edited:

pintree3

Senior Member
#7
Untitled-4.jpg Thanks again
I decided to do what u did so u can see. These were my steps; Opened a file from within the external drive and made a few changes -2- saved the file on the internal drive (and took screen shots of its properties). -3- moved this same file back to the external drive (and took shots of its properties).
You will notice that -a- one extra permission category is created on the one moved to the external drive and -b- permissions are granted to everyone all the way.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top