Screen wont turn off when I close laptop lid

#1
Hello,

I have recentley installed Windows 7 RC. Since installing it, I have noticed that when I close my laptop lid, the screen stays on. How do I get the screen to turn off without going into sleep or hibernate mode? I've tried messing around with the power options but nothing seems to work.

Thanks for your help.
 


reghakr

Essential Member
#2
Hello and welcome,

I' haven't had a laptop in years, but isn't it common practice to set Notebook to hibernate.

For more detailed information, go to Start > Help and Support and type in laptop power.
 


#3
When I am downloading something I usually close the lid and let it get on with it. If I was to put it in hibernation, I wouldnt be able to download anything. When I am at home, I usually just have the laptop connected to mains and have it on all the time but prefer the screen to be off when Im not using it.

P.S. Thanks for the welcome! :)
 


reghakr

Essential Member
#4
Did this occur immediately after install.

Do you recall making any major changes or install any software that may have caused this?

Are you on a slow dial-up connection where the downloads take a long time?
 


#5
I was on Windows XP prior to that and the screen turned off when I closed the lid.

I recently installed Windows 7 drivers for my graphics card, im not sure what the situation regarding the screen was before that as I hadnt closed the lid before I installed the new drivers. I've got ATI Mobility Radeon X1300 if that helps.

My download speeds arent slow but like I said, I usually just leave my laptop on when I am at home even if its not downloading or running anything.

Thanks for your replies.
 


reghakr

Essential Member
#6
This site has the latest drivers for the Radeon series. Please check you version before attempting the download and be sure to create a restore point.

If you have a AMD 7-Series chipset, you can update that here

Drivers & Tools | GAME.AMD.COM

There is also a tool for modifications here
 


Last edited by a moderator:
#7
Thanks for your help mate. Unfortunatly I already have the latest driver. I guess I'll just have to live with it until Windows 7 is released. Thanks for your time!
 


reghakr

Essential Member
#8
Your most welcome,

I wish I could have provided a better answer.

However, you are right, I'm sure with the final release this problem will be corrected most likely by ATI with re-written drivers.
 


p4r45

New Member
#9
Figured it out!

In the power options, go to Change Plan Settings and theres an option to 'Turn off the display' after a certain amount of minutes! Dont know how I missed this the first time! Hope this helps anybody else with the same issue!
 


Last edited:

reghakr

Essential Member
#10
NICE going,

I sometimes miss the easy ones, but can solve the difficult posts.:rolleyes:
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.