Search not working for new HDD

Discussion in 'Windows Vista Help and Support' started by Erica, Aug 6, 2008.

  1. Erica

    Erica Guest

    I've had this computer since december, and have only ever had Vista on it. I got a new hard drive thats about a month old. Its been working fine as my storage, but when I try to use the search feature, no files show up. I'm computer literate, and know I am searching correctly. I also check to search for non indexed files, with no results still.

    My searches work perfectly fine on my origional hard drive, that also has windows installed. Also, if I plus in a USB or external hard drive, the search works fine on those as well. If anyone has any ideas, please let me know! Thanks!
     
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,789
    Likes Received:
    1,563
    Try opening the control panel clicking 'system and maintenance' and then 'Indexing Options'. You should be able to add the new HDD location to the index list. Hope that helps..
     
  3. Erica

    Erica Guest

  4. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,789
    Likes Received:
    1,563
    Yup I did mean there....So I guess it didn't work?... Hmm...Try right clicking the 'start' button and choosing properties. If you then click 'customize' and scroll down to where it says 'Search entire index', tick that.. Hopefully that'll do the trick.
     
  5. Erica

    Erica Guest

    I tried that but it didn't seem to help either. Search still works fine on the main drive, and external/flash drives so I'm stumped too. My secondary HDD is a 500gb Western Digital SCSI and as I said works perfectly normal minus the search feature. Any other ideas would be great, and thanks again for taking the time to help :)
     
  6. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    I don't have the index on in my setup so I cannot test it but - Have you tried right clicking the drive in Windows Explorer, select properties and under the general tab, "Index this file for faster searching. (It's a small square at the bottom left)
     
  7. Erica

    Erica Guest

    I checked, and do have indexing checked. I would think though, that indexing has nothing to do with it ( though im no vista expert ) since I have the option to search for files that are not indexed, and still have 0 results. :(
     
  8. stellfox

    stellfox New Member

    Joined:
    Aug 13, 2008
    Messages:
    10
    Likes Received:
    0
    If I were you, I'll try to go into the Advanced options and try restoring defaults so the index will automatically be set to default or rebuild the index.
     

Share This Page

Loading...