Second Internal Hard Drive won't show up on wake up

Discussion in 'Windows 7 Hardware' started by EbbFlowe, Oct 15, 2009.

  1. EbbFlowe

    EbbFlowe New Member

    Joined:
    Oct 15, 2009
    Messages:
    2
    Likes Received:
    0
    The topic should pretty much explain the problem I'm having.

    When I turn on/restart the computer, the desktop itself has two hard drives in it (250GB and 1TB, 1TB is not the one the OS is on)

    When I put the computer to sleep, and then wake it up, the 1TB is not active, and to access it I have to completely restart the computer. Does anyone have the same problem? And if so, does anyone have a fix for it? Thanks!

    I'm using a legitimate retail version of Windows 7 Ultimate, if that helps any?
     
    #1 EbbFlowe, Oct 15, 2009
    Last edited: Oct 15, 2009
  2. KKCC

    KKCC New Member

    Joined:
    Jan 8, 2010
    Messages:
    10
    Likes Received:
    0
    I have EXACTLY the same problem. I have a generic Lenovo so nothing unusual about my PC.
    I use Windows 7 - 64bit. The second drive is 1.5 TB. I have also had the same problem with a 1 TB second drive.
    When the PC wakes up from a sleep my internal SATA HD shows up for a few seconds then disappears.

    I -was- rebooting to get it to show but I found that if I put the PC -back- to sleep for a few seconds, then wake it again the HD will show after about 10 seconds. Windows will then start the display that shows a new media being discovered and wants to know what I want to do. (I turned that off after a few times of being annoyed)
     
  3. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Well, just to start, could you attach a snipping tool picture of your disk management window?

    Are your drives set up for IDE or AHCI in the bios? Do you have them on the SATA 0 and Sata 1 connectors?

    Are your drives of the "Green" type where they slow down during low activity periods?

    If you want something to do ;) close down any unnecessary programs. Then open an adminstrative command prompt and type:
    powercfg -energy

    It will take about a minute to run a test and make a report. Make note of where the report is stored and the name before you close the command window. It may, or may not help point to a problem.

    Oh, by the way, next time you need to access the drive in this situation, try opening Device Manager and select "scan for hardware changes".
     
    #3 Saltgrass, Jan 8, 2010
    Last edited: Jan 8, 2010
  4. KKCC

    KKCC New Member

    Joined:
    Jan 8, 2010
    Messages:
    10
    Likes Received:
    0
    Thank you for the reply-

    I previously tried POWERCFG and didn't see anything that appeared unusual.

    I have TWO drives that exhibit the same problem. One is a 1 TB WD Caviar Green, the other is a 1.5 TB Seagate.
    I currently have the Seagate as Drive E and the WD as Drive D.
    They are set to AHCI. I do not believe they will work as IDE.

    Drive D (SATA-1-sometimes- will not wake up.
    Drive E (SATA-2) -never- comes out of sleep unless I reboot or put it back to sleep then wake it up quickly.

    I have looked at the 'SPIN UP' times on both drives and neither shows to be out of specs.
    I attached what you requested plus the DRIVES list.

    PC= Lenovo H230 w/Windows 7 Professional
     
  5. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I do not know if the ACHI setting might be effecting the situation. It is reported to be better for large hard drives, which you certainly seem to have. I was thinking, and no proof at all, that the fact they might be considered hot bootable, that they might be disconnecting thinking the system was off or something.

    All I might suggest is to maybe adjust the power settings on the drives to change how they sleep to see if anything improves.

    In device manager, under the drive properties and the policies tab, there is a check box for Enable write caching. You might try changing these settings to see if it might help.

    Have you tried reversing the SATA connectors on the 2 large hard drives, or removing one to see if the other works better. This would of course be a problem if you have programs that depend on those Drive letters.

    Just guessing since I have no proven solution.
     
  6. KKCC

    KKCC New Member

    Joined:
    Jan 8, 2010
    Messages:
    10
    Likes Received:
    0
    I believe if you change the drive setting to IDE it will cause your SATA HDD to be emulated as a PATA. It and the RAID option didn't seem to function correctly when I tried it some time ago.

    I tried changing the power settings various ways and I flipped the WRITE CACHING also but I appreciate the suggestions.

    I have the drives 'sleep' after a shorter period than the PC and they always seem to 'wake up' when I want to use them. It's only when the PC sleeps that they don't.
    It's almost like there is a 'timer' when the PC wakes up where it expects the drives to be awake and when they aren't it drops them. It's probably a REGISTRY entry somewhere. Guess I could try and get a REGISTRY trace figured out that might show me whats going on. That might be hard to do in sleep mode.

    I was hoping someone might have had this problem and has it figured out but I'm still open to any and all suggestions on something to try.
     
  7. KKCC

    KKCC New Member

    Joined:
    Jan 8, 2010
    Messages:
    10
    Likes Received:
    0
    Don't know if anyone has posted this but there is a hotfix that cured my problem. Apparently SATA large drive are a little slower to wake up and Windows 7 doesn't wait long enough.

    http://support.microsoft.com/kb/977178/#top
     
  8. ruggb

    ruggb Honorable Member

    Joined:
    Jan 14, 2009
    Messages:
    510
    Likes Received:
    4
    hello, did this fix anyone's problem?????????
     
  9. James Kiryakoza

    James Kiryakoza New Member

    Joined:
    Dec 28, 2011
    Messages:
    2
    Likes Received:
    0
    As suggested above, opening Device Manager and select "scan for hardware changes" woke up my drive without having to reboot. Still no permanent fix for me though.
     

Share This Page

Loading...