Secondary HDD, File management, Administrative Permission Problems

Discussion in 'Windows 7 Help and Support' started by TheHumanParadox, Apr 18, 2010.

  1. TheHumanParadox

    TheHumanParadox New Member

    Jan 13, 2009
    Likes Received:
    Greetings Win7 users, I could use your help.

    Here's the story: I have Win7 Ultimate x32 (relatively) recently installed on a pc with two HDD's, a 250g and a 500g. I use the 250g as a system partition and the 500g as a media drive (music, videos, photos); I carried this one over from a previous installation, while reformatting the 250g drive with Win7. It's a fairly normal setup I'd say.

    However, lately I've been having ENORMOUS issues with the Permissions in Win7. It started out simply not being able to access any of the folders on my media drive, which I fixed with a right-click Take Ownership .dll fix, and that worked for a while. However, lately something else is going on: I can access the files fine in Explorer, but programs cannot write to them. An example: I have my iTunes library redirected to my secondary 500g drive, and when I drag files over it's "supposed" to (and used to) copy the music to my media drive. Lately, I've been getting permissions errors while trying to do this, as well as when trying to update the program. There are other issues I've been having but at the moment, this is the biggest one; I use iTunes incredibly often.

    I've researched the heck out of how to give myself full Administrative rights, and have spent much time frustratingly trying to fiddle with the permissions of the HDD, to no avail. The only way I found was enabling the hidden Global Administrator, which doesn't help my current Win7 account. If anyone has dealt with this issue, they can tell you it's extremely irritating...

    So, any help with either fixing my permissions or turning my current account into the Global Administrator would be awesome. And if this has already been discussed/solved, apologies, a point in the right direction would be nice.

  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Aug 28, 2007
    Likes Received:
    Hi Human,
    one quick question, have you tried turning off the UAC? From the sounds of it you probably have but just thought I'd ask....
  3. RAK

    RAK Extraordinary Member

    Jul 6, 2009
    Likes Received:
    As you guessed, there are a couple of threads relating to global admin rights but, if Kemical's suggestion does not do the trick, to save you time, here it is:
    There are a couple of ways:

    Open a command prompt(Run as Administrator).
    Type the following command and enter.
    net user administrator /active
    Log out and see if you have a new alternative login, as well as your existing one. If not, do it the long way.
    Shut down the computer for a cold boot. Tap the "F8" key as you are booting.
    Select "Safe Mode with networking" from the boot menu.
    Log into windows 7 with your personal account that holds the administrator access.
    Open a command window (START--->RUN--->CMD.exe). At the command prompt type the following net user administrator /active
    Log out and log back in as administrator.

    Another way
    Go to Start
    Type Control UserPasswords2.
    Click Advanced.
    Click Advanced again.
    Select Users.
    Select Administrator and untick the the box “Administrator is disabled”
    Now log out and login as Administrator.
    The action leaves you a little more vulnerable to outside attack. Not a big issue if you are confident with your anti virus control etc.

    I somehow do not think it will work, however. The permissions may have been locked by the previous OS, from which you took the HD.
    Referring to the "take ownership" option. You maybe aware that this can be used globally. If you click a folder, it will take ownership of all theirin.
  4. TheHumanParadox

    TheHumanParadox New Member

    Jan 13, 2009
    Likes Received:
    Thanks for the replies guys.

    Kemical- Yeah, I do have UAC turned off, though I should have said so haha

    RAK- Thanks, that's probably what I'll end up doing. I just have some account-specific customized settings for my current account, and the Global Admin doesn't have those. I may just end up using the Global Admin if that's the only way to access my files. I'm quite hoping that it's not something to do with the previous OS on the HDD, because I don't really have a way to copy my data off, reformat, and copy back.

Share This Page