Services fail to start, no internet or usb

Discussion in 'Windows 7 Help and Support' started by regel, Jun 10, 2011.

  1. regel

    regel New Member

    Joined:
    Jun 10, 2011
    Messages:
    4
    Likes Received:
    0
    Hi. I have a Gateway T-6836, updated to Windows 7 Ultimate 64-bit a few months ago from Windows Vista Home Premium 64-bit. I've had it for about 2 years, After 1 year a virus killed it, and I reformatted it. Now, a few months ago, unknowingly, my flash drive contracted a virus from my school's pc and infected my laptop. I think I most likely deleted the malware or whatever it was, but it left some side effects, such as some services being unable to start. It was also at the same time I installed a windows update, so I'm not sure if it's both a malware problem and/or a Microsoft problem. It deleted all my system restore points after I restarted the computer.

    My laptop is completely isolated from the world. No internet, fails to detect anything in the usb slots, and the CD-rom is broken

    When I'm not connected to a network, there's a yellow asterisk sign, when I'm connected there's a big red X button and I get 'limited connectivity.' When I try to troubleshoot the problem, it gives me "The Diagnostics Policy Service is not running" Tried to repair it and failed. I tried starting it manually in Services but that gives me "Windows could not start the Diagnostic Policy Service service on Local Computer. Error 5: Access is denied."

    Tried perfmon /repair failed. It gave me an error:

    "Error:
    An error occured whiled attempting to generate the report.

    The service did not respond to the start or control request in a timely fashion."
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Well, a good place to start would be to open an administrative command prompt and type the following and enter after.

    SFC /scannow

    Let it work and see what the results are. Hopefully the system file check will repair your files or at least some to get you closer to a normal system.

    Have you been able to run any anti-virus programs lately?

    It is strange when you are denied any access to some device that might help get your system running again.....almost like it was planned that way...
     
  3. regel

    regel New Member

    Joined:
    Jun 10, 2011
    Messages:
    4
    Likes Received:
    0
    UPDATE:
    Ok, apparently I can access the internet via Ethernet cable, but wireless is still messed up. It still gives me "The dependency services or group failed to start." in Network and Sharing Center. After discovering I could use the internet via Ethernet cable, I found this guide: Malware Removal Guide for Windows and now I can use my USB ports again, and boot time is back to normal (it took about 20 minutes to 1 hour at the windows logo screen before, and sometimes I'd get BSOD). But some services are still denied access.

    @Saltgrass I will try this, thanks.
     
  4. Paul12

    Paul12 New Member

    Joined:
    Apr 10, 2011
    Messages:
    2
    Likes Received:
    0
    Hi regel,

    I'm glad you found the guide helpful.
     

Share This Page

Loading...