Shutdown Problem

Discussion in 'Windows 7 Help and Support' started by benjaminyau2005, Dec 20, 2010.

  1. benjaminyau2005

    benjaminyau2005 New Member

    Joined:
    Dec 20, 2010
    Messages:
    18
    Likes Received:
    0
    I recently upgraded my Dell Studio 1558 laptop from the orignal Windows 7 Home Premium 64-bit OS to the Windows 7 Ultimate 64-bit OS. Now, whenever I try to shut down my laptop, it displays the normal "Shutting Down" screen. However, it stays on the screen indefinitely, and my laptop never shuts down. Then, I have to manually press the power button to turn it off. However, there are no error messages at all. I do not even get the message saying Windows had shut down improperly last time. Please help me. Thanks.
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I would have to guess the upgrade left something that is causing problems.

    Try shutting down all unnecessary programs. Open a Command Prompt using the run as administrator option and type:

    powercfg -energy

    Keep track where the resulting report is located and open it to see if anything might suggest a problem.

    If that doesn't help, try running a system file check by opening the same administrative command window and type:

    sfc /scannow

    Allow it to finish to see if any system files have been replaced or need to be replaced.
     
  3. benjaminyau2005

    benjaminyau2005 New Member

    Joined:
    Dec 20, 2010
    Messages:
    18
    Likes Received:
    0
    I did the powercfg /energy and here is what I got:

    3 Errors
    7 Warnings
    21 Informational

    See C:/Windows/system32/energy-report.html for more details.

    So, I opened the location, and found energy-report.html, but when I tried to open it, it just opened up my home page on Internet Explorer.

    On sfc /scannow, here is what I got:


    Windows Resource Protection did not find any integrity violations.
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    The energy report on my system was about 18K in size. You might check to see if yours is not a 0 file for some reason. I just double click mine and it opened. If yours will not work that way, try opening it from within IE by dragging into the window of file open (Ctrl + o).

    If you can't open it, try doing another one using the elevated administrative command window. The information in the file may not lead to a fix for your problem, but command should work. There are other powercfg options you can use and type powercfg -help to get a list.
     
  5. benjaminyau2005

    benjaminyau2005 New Member

    Joined:
    Dec 20, 2010
    Messages:
    18
    Likes Received:
    0
    I tried all the solutions that you gave me, and I still cannot open the file. Is there any other way to solve this problem other than opening the file?

    Also, this is kind of off topic, but I also have this message that says "This computer is configured to require a password in order to start up. Please enter the startup password below." I know the password, but do you know how to get rid of it? Thanks.
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    The password you seem to be referring to should be set up in the bios. There is probably some option to not use a password on one of the pages.

    The powercfg utility is certainly optional. But if it is some type of power problem, it might help. The fact you cannot open the file might be an illustration of part of the problem. I assume you checked the file and it is not showing as a zero size file.

    Do you show any error or warning messages in the event viewer (eventvwr.msc)? Since you said you had not gotten any error messages, I just need to ask to make sure you did not notice something.

    Other things you might check are hardware incompatibilities, or utilities that do not cooperate. Have you ever gotten a shutdown message about some utility that has not closed? Are there any external devices you can unplug?

    If all else fails and you desire to correct the problem, a repair install might be required. It looks like more testing should be done prior to this, but it is an option and leaves your system in its current configuration.
     
    #6 Saltgrass, Dec 21, 2010
    Last edited: Dec 21, 2010
  7. benjaminyau2005

    benjaminyau2005 New Member

    Joined:
    Dec 20, 2010
    Messages:
    18
    Likes Received:
    0
    As for the password problem, I checked the BIOS, and it does not seem to be set up there. I think it is probably somewhere in the Local Security Policy because I remebered messing around with it yesterday.

    As for the shutdown problem, the energy-report file size is 27.2 KB. But, I still cannot open the file in any way. However, when I checked the Event Viewer, I got this message that I think might help. I have attached a screenshot of it as an attachment to this post.

    Also, how would I check for hardware incompatibilities, or utilities that do not cooperate. As for shutdown messages, I never got any. And, there are no more external devices that I can unplug.

    If all else fails, how do I do a repair install? I do not have the Windows 7 Installation CD. I upgraded it using Windows Anytime Upgrade and entered my product key. Thank you very much for your help.
     

    Attached Files:

    #7 benjaminyau2005, Dec 22, 2010
    Last edited: Dec 22, 2010
  8. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Type msinfo32 in the start menu then press enter. File | save on the opened screen. Zip the saved file then attach here. I'll have a look at drivers/software which need to be updated or removed, which has an excellent chance to fix it.
     
  9. benjaminyau2005

    benjaminyau2005 New Member

    Joined:
    Dec 20, 2010
    Messages:
    18
    Likes Received:
    0
    I fixed the password problem by doing a System Restore.

    @TorrentG:

    I have attached the file to this post. Please take a look. Thank you very much.
     

    Attached Files:

  10. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    I really couldn't make much of it, because the file reports it is either corrupt or incompatible with my version of the system .nfo reader. It happens rarely, but this is one of those times.

    I was however, able to see that a program from ST Microelectronics starts with the pc called Accelerometer.

    I would uninstall that as a test.

    If still needed to try, type msconfig in the start menu then press enter. On the General tab, click the radio button for Diagnostic startup. Hit ok then reboot.

    Test it out like this. If good, then you can go back to msconfig, click Normal startup then hit ok.

    Go to Services tab. Click the box to Hide all Microsoft services. Then click Disable all. Hit ok then reboot and test.

    If good, re-enable the startup services one by one while rebooting after, to test.

    This way, you can likely find which is the culprit.
     
  11. benjaminyau2005

    benjaminyau2005 New Member

    Joined:
    Dec 20, 2010
    Messages:
    18
    Likes Received:
    0
    I tried all the ideas you gave me, but it still doesn't work.:frown:
     
  12. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    The Kernel Power message is probably the result of the problem and not the problem.

    I could not open your info report either, but you might check it for Problem Devices and look at the Startup Programs and possibly post a picture using the snipping tool to take it.

    If you would feel comfortable, since it might have some personal info, send the energy report to me or attach it to see if we can open it.

    Since it seems certain files do not work correctly, I need to ask if you have run any virus scans recently?
     
  13. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Kernel-Power means a bsod happened...

    So the crash dumps will be very helpful here for sure. C:\Windows\Minidump

    Copy the files in there to any other folder, then zip them and attach the zip here.
     
  14. benjaminyau2005

    benjaminyau2005 New Member

    Joined:
    Dec 20, 2010
    Messages:
    18
    Likes Received:
    0
    @Saltgrass:

    I have attached it to the zip file. It is under the folder called "Energy Report". Also, I checked the Problem Drivers and Startup Prgrams. I did not get anything for Problem Drivers, and I have attached the snip of the Program Files in the folder called "Startup Program" from the System Information. Recently, I did run a virus scan using the original McAfee Virus Scan that came with my computer. Thank you.

    @TorrentG:

    Here are the minidump files. It is under the folder "Minidump Files." Thank you.

    For your information, I will get my motherboard and hard drive replaced tomorrow for free, to see if it does any good.
     

    Attached Files:

    #14 benjaminyau2005, Dec 22, 2010
    Last edited: Dec 22, 2010
  15. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Well, the file opened fine on my system. A picture of the errors is below. It seems the USB system has some devices that are causing problems. I will have to check, but if you go to device manager and check the properties for your devices, you might be able to tell which devices are involved.

    Also it seems McAfee is using quite a bit of processing time. Is that the anti-virus you are using?

    It also seems to indicate the wireless adapter is not set up do go into sleep mode, so you might check that. I have also attached a Word version of your report.
     

    Attached Files:

    #15 Saltgrass, Dec 22, 2010
    Last edited: Dec 22, 2010
  16. benjaminyau2005

    benjaminyau2005 New Member

    Joined:
    Dec 20, 2010
    Messages:
    18
    Likes Received:
    0
    By magic, I some how opened the energy report file. I checked the USB device drivers, and everything seems to be working fine, and up to date. Also, McAfee is the anti-virus software that I am using. How would I set up the wireless adapter to go into sleep mode?
     
  17. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Alright, culprits have been found.

    Follow my signature about Daemon Tools and sptd.sys.

    ---------

    Navigate to C:\Windows\System32\drivers and delete this then reboot:

    PxHlpa64 PxHlpa64.sys Tue Jun 23 19:16:35 2009

    ---------

    Uninstall your Creative video software normally. Then reboot to safe mode and use Driver Sweeper to clear all Creative stuff:

    CtClsFlt CtClsFlt.sys Mon Jun 15 01:06:41 2009

    Reboot and visit Creative's site to install the latest driver package for your hardware:

    Phyxion.net | Driver Sweeper | Products | Products

    ------------------

    Update Intel wireless driver from Intel's website:

    NETw5s64 NETw5s64.sys Tue Sep 15 15:40:39 2009

    ------------

    Update Synaptics Touchpad driver:

    SynTP SynTP.sys Mon Aug 24 13:37:05 2009

    Download License Agreement | Synaptics
     
  18. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    If you are replacing the internal on your system, we will wait until that is done and you have it running again. Let us know how you reinstall Win 7, and are you using the Dell Drivers (if there are any) after you finish or just using the Win 7 installed ones?

    To answer the earlier question about sleep mode on the Wireless adapter, open the Network and Sharing Center, then Change Adapter Settings, Properties, Configure and look under the Power Management tab.
     
    #18 Saltgrass, Dec 23, 2010
    Last edited: Dec 23, 2010
  19. benjaminyau2005

    benjaminyau2005 New Member

    Joined:
    Dec 20, 2010
    Messages:
    18
    Likes Received:
    0
    Thank you for all your help. I just got a replacement of my motherboard and hard drive from Dell along with labor for free today, since my laptop is still under warranty because it is only 6 months old. Too bad I did not read TorrentG's post before I contacted Dell to replace my parts, but at least I got a free replacement and labor. But, I am still interested in finding out how TorrentG found the culprit. I am not sure if that is the culprit, since I did not get a chance to try it, but I am a computer science major, and I wish to find out how to solve the problem if it occurs again in the future. However, I will not be able to read the post until Sunday because I am going down to Mexico tomorrow, but please post it. For Saltgrass, when Dell replaced the hard drive, and powered on the laptop, everything just went back to factory defaults. They did not have to install any disks or anything. For the both of you, it would be great if you could delete the energy report and/or system information from your earlier post and/or computer if possible, since it might contain personal information. Thank you very much for your cooperation in advance, and for helping me solve this problem.
     
    #19 benjaminyau2005, Dec 24, 2010
    Last edited: Dec 24, 2010

Share This Page

Loading...