Side by side configuration

#1
Hi,
i have a problem when trying to launch some .exe files. And when i launch them i get this error "The application has failed to start becouse its side by side confoguration is incoret.... "
I know that it isnt the programs foult becouse last time when i tried to run it, the programm worked, then after some time i re-instaled same windows from same cd and wanted to run the program again. I re-instaled win like 5x times.
Re-installed vc redist, 2005, 2008, 2010 but no use, still it didnt work.

This is the error what i get from event wiever:
Activation context generation failed for "D:\RFONLINE\224\SERVER\account\RF_Bin\LoginServerSD.exe". Dependent Assembly Microsoft.VC80.DebugCRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.4053" could not be found. Please use sxstrace.exe for detailed diagnosis.

So, i tried to google the problem.
I have spent like 48h on google....
Then i tried to test the .exe file with dependancy walker, and when i test it i get fallowing error:


Error: At least one module has an unresolved import due to a missing export function in an implicitly dependent module.Error: Modules with different CPU types were found.
Error: The Side-by-Side configuration information in "d:\rfonline\224\server\account\rf_bin\LOGINSERVERSD.EXE" contains errors. The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail (14001).
Warning: At least one delay-load dependency module was not found.
Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.


iT says that msvcp.dll was not found, but i can see the .dll in the folder, but still it says that it wasnt found.

Does somebody know what is the problem ? (win 7 x64 ultimate)
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#2
Hi

Did you try running Scf /scannow from the prompt?

From the elevated Prompt Right click on the Prompt Icon and select run as administrator.
Then type…

Scf /scannow

Scans and restores system files.

Mike

Take a look at this too!

msvcp71.dll free download - DLL-files.com
 


Last edited:
#3
Did you try running Scf /scannow from the prompt?
Sorry for the correction Mike, but that would be SFC /scannow

Regards,

Don
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#4
No wonder it didn't work! LOL
Well I didn't learn to type until I was 60.
 


davehc

Essential Member
Premium Supporter
Microsoft MVP
#5
At least you learned. I'm still battling. A few years on top of 60 - lol.
 


#6
o_O where did those 5 posts go ? Did someone delete them ? Nvm
So i tried upgrading windows like you told me, tried removing service pack sp1 (i didnt have one at updates list), when i upgraded my win it became 40% slower idk why. So i just for 50x time re-installed windows (i think my dvd drive and hdd are starting to die because of this, even win 7 installations are getting slower and slower, so i need to fix the problem with side by side error before my pc dies :D )

So, like i sad i just re-installed win. And i wanted to test what will happen when i try to launch the program without ant vc redists.
So i found a earlier version of my program (2.2.3), when i try to run it starts without ant problems o_O, how this could be, there is no vc redists installed ??? And when i try to launch the 2.2.4 version (from what i did get side by side error), it tells my that side by side in incorrect, and that this version could not be found:
Microsoft.VC80.DebugCRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.4053" could not be found. Please use sxstrace.exe for detailed diagnosis.


So why is did ? Does this mean that windows installs vc redist version needed form earlier program version, but no for latest(2.2.4) ???
 


Captain Jack

Extraordinary Member
#7
#8
I tried uninstalling / reinstalling the VS redistributables and this did not correct my problem. I needed to go and reinstall windows 7 altogether which corrected the issue.

Hope this helps.
 


Mychal

Senior Member
#9
I also have this error running win 7 x64:
Activation context generation failed for "C:\Windows\WinSxS\x86_microsoft.vc80.mfc_1fc8b3b9a1e18e3b_8.0.50727.6195_none_cbf5e994470a1a8f\MFC80.DLL". Dependent Assembly Microsoft.VC80.MFCLOC,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50608.0" could not be found. Please use sxstrace.exe for detailed diagnosis.

Please advise as to how I can eliminate this error from event viewer. Thank you.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.