Slow download and upload speeds...

Hi all. I just finished a fresh install of Windows 7 64-bit on a brand new computer yesterday.

Here are the specs:

Asus P6T mobo
nVidia GTX 275
seagate 500 gb hard drive
6gb kingston ram

My problem is that my download/upload speeds have decreased significantly, on the same network that I had been using a different computer on previously. I used to be able to download things at at least 500 kb/s, but now I'm lucky if I can get it over 50 kb/s. Upload speeds have been throttled too.

My network adapter is a Realtek PCIe GBE family controller. This is a hard-wired connection, so no wireless card. I've tried the command prompt line I've seen in other threads concerning similar issues, disabled QoS, tried starting in safe mode, tried rebooting a thousand times, uninstalled the network adapter and installed the newest one from Realtek. None of these things has helped. I even tried using a different ethernet cable.

I'm so confused. It's taking insanely long times just to download small files. I live in a dorm where we plug our computers straight into the ethernet port in the wall, so there is no router to complicate the issue.

Furthermore, when I view the details of my network connection, it says the speed is 100mbps. It just doesn't behave as if that's the case.

Can anyone help?


Essential Member
Have you tried to update the drivers here:


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.